Project

General

Profile

Bug #9888

Capsule: openSSL not getting pulled in as a dep?

Added by dustin tsang over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1202963
Description of problem:
Trying to install capsule when openssl is not installed on a box throws an error

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-7-20150311.1

How reproducible:

Steps to Reproduce:
1. Provision a new RHEL 7.1 box. assure that openssl is not installed.
2. Register box to existing satellite that has RHEL content and capsule/sat repos synced.
3. yum -y capsule-installer on target capsule box
4. Execute capsule-installer with your desired parameters

Actual results:

  1. capsule-installer -v --certs-tar rhsm-qe-3.rhq.lab.eng.bos.redhat.com-certs.tar --parent-fqdn rhsm-qe-2.rhq.lab.eng.bos.redhat.com --pulp true --pulp-oauth-secret o2QYsWFB2PHY9nAV96mUtMKruXn626Zq --puppet true --puppetca true --foreman-oauth-secret Hebf8gVqzH73DqokbzJnMWAVc6Qa5EGy --foreman-oauth-key qpcfyaEKGVXi4xizKZz68k8jTfh4ijbE --register-in-foreman true --qpid-router "true" --reverse-proxy=true

[...output truncated...]

[ERROR 2015-03-17 15:19:39 verbose] No such file or directory - openssl at /usr/share/katello-installer/modules/certs/manifests/init.pp:123 on node rhsm-qe-3.rhq.lab.eng.bos.redhat.com
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/katello-installer/modules/common/lib/puppet/parser/functions/generate_password.rb:4:in ``'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/katello-installer/modules/common/lib/puppet/parser/functions/generate_password.rb:4:in `block in <module:Functions>'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:170:in `block (2 levels) in newfunction'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler/none.rb:6:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:43:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:163:in `block in newfunction'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/function.rb:42:in `evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/astarray.rb:25:in `block in evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/astarray.rb:20:in `each'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/astarray.rb:20:in `evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/function.rb:37:in `evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/vardef.rb:14:in `evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:11:in `block in evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `each'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/resource/type.rb:122:in `evaluate_code'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:79:in `evaluate'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:352:in `block (4 levels) in evaluate_definitions'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler/none.rb:6:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:43:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:351:in `block (3 levels) in evaluate_definitions'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:350:in `each'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:350:in `block (2 levels) in evaluate_definitions'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler/none.rb:6:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:43:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:349:in `block in evaluate_definitions'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/errors.rb:62:in `exceptwrap'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:348:in `evaluate_definitions'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:371:in `block (2 levels) in evaluate_generators'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler/none.rb:6:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:43:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:368:in `block in evaluate_generators'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:365:in `loop'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:365:in `evaluate_generators'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:126:in `block (2 levels) in compile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler/none.rb:6:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:43:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:126:in `block in compile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet.rb:234:in `override'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:106:in `compile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:23:in `compile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:95:in `block (2 levels) in compile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler/none.rb:6:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:43:in `profile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:93:in `block in compile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util.rb:161:in `block in benchmark'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/benchmark.rb:296:in `realtime'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util.rb:160:in `benchmark'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:92:in `compile'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:52:in `find'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/indirector/indirection.rb:201:in `find'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:214:in `block in main'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet.rb:234:in `override'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:190:in `main'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:151:in `run_command'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/application.rb:371:in `block (2 levels) in run'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/application.rb:477:in `plugin_hook'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/application.rb:371:in `block in run'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util.rb:479:in `exit_on_fail'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/application.rb:371:in `run'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:137:in `run'
[ INFO 2015-03-17 15:19:39 verbose] /usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:91:in `execute'
[ INFO 2015-03-17 15:19:39 verbose] /usr/bin/puppet:8:in `<main>'
[ INFO 2015-03-17 15:19:39 verbose] Puppet has finished, bye!
[ INFO 2015-03-17 15:19:39 verbose] Executing hooks in group post
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/capsule-installer/capsule-installer.log
[ INFO 2015-03-17 15:19:39 verbose] All hooks in group post finished
[ERROR 2015-03-17 15:19:39 verbose] Repeating errors encountered during run:
[ERROR 2015-03-17 15:19:39 verbose] No such file or directory - openssl at /usr/share/katello-installer/modules/certs/manifests/init.pp:123 on node rhsm-qe-3.rhq.lab.eng.bos.redhat.com
[ERROR 2015-03-17 15:19:39 verbose] No such file or directory - openssl at /usr/share/katello-installer/modules/certs/manifests/init.pp:123 on node rhsm-qe-3.rhq.lab.eng.bos.redhat.com

Expected results:

Openssl should be pulled in as a dep.
Note that if you manually install 'openssl' and rerun your capsule-installer, you tend to get further along.

Additional info:

Associated revisions

Revision 8dde1e37 (diff)
Added by dustin tsang over 6 years ago

Fixes #9888 - use random_password over generate_password

generate_password has a dependency on openssl.

Revision cec063aa
Added by dustin tsang over 6 years ago

Merge pull request #57 from dustints/9888

Fixes #9888 - use random_password over generate_password

Revision 794b34ee (diff)
Added by dustin tsang over 6 years ago

Fixes #9888 - require openssl for katello-installer-base

  • katello-certs-check relies on openssl being present
  • use random_password instead of generate_password (generate_password
    depends on openssl)

Revision b5477561
Added by dustin tsang over 6 years ago

Merge pull request #198 from dustints/9888

Fixes #9888 - require openssl for katello-installer-base

History

#1 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 68
  • Pull request https://github.com/Katello/katello-installer/pull/198 added
  • Pull request deleted ()

#2 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

#3 Updated by dustin tsang over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF