Project

General

Profile

Bug #9890

Trying to remove a content view indicates "affected hosts" that do not use said CV

Added by Partha Aji over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1205379
Description of problem:

When you have two parallel content paths - say, RHEL6 and RHEL7 - and systems registered using each, subsequently trying to remove one of the paths, indicates "affected hosts" that do not actually consume content from that CV.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Sync RHEL6 content; create RHEL6 CV/pub/promote; add RHEL6CV to ak
2. Register RHEL6 box(es)
3. Sync RHEL7 content; create RHEL7 CV/pub/promote; add RHEL67V to ak
4. Register RHEL7 box(es)
5. Attempt to remove RHEL6 CV (first remove rhel6 AK, etc., I think?) * Remove View > Remove Version > Next * Show Affected Content Hosts

Actual results:

Hosts that show up in "Affected Content Hosts" that are not RHEL6 and/or should not be affected.

Expected results:
We should not show hosts that are not affected

Additional info:
This is more critical than it looks because I am forced to move those hosts somewhere else (even though they don't need to be) in order to remove the view.

Associated revisions

Revision b27e0a42 (diff)
Added by David Davis over 6 years ago

Fixes #9890 - Add content_view_id to systems API

Revision e0dd5dd4
Added by David Davis over 6 years ago

Merge pull request #5137 from daviddavis/temp/20150324165507

Fixes #9890 - Add content_view_id to systems API

History

#1 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 68
  • Pull request https://github.com/Katello/katello/pull/5137 added
  • Pull request deleted ()

#2 Updated by David Davis over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

Also available in: Atom PDF