Project

General

Profile

Bug #9935

Incremental update with errata apply fails to send errata for client update

Added by Justin Sherrill over 7 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When performing an incremental update if you check the box to apply the errata to clients, the update is initiated but a blank errata list is sent.

this was caused by: https://github.com/Katello/katello/pull/5120

In that case the incremental_updates action was updated to send errata_ids but the applicable_errata_install takes uuids

Associated revisions

Revision a6155a23 (diff)
Added by Justin Sherrill over 7 years ago

fixes #9935 - pass correct id to install errata for inc updates

Revision a8b261b6
Added by Justin Sherrill over 7 years ago

Merge pull request #5152 from jlsherrill/9935

fixes #9935 - pass correct id to install errata for inc updates

History

#1 Updated by The Foreman Bot over 7 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5152 added
  • Pull request deleted ()

#2 Updated by Justin Sherrill over 7 years ago

  • Bugzilla link set to 1206716

#3 Updated by Justin Sherrill over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF