Project

General

Profile

Bug #9936

katello-installer 2.1 fails due to foreman-rake-db:migrate when following yum install procedure on CentOS 6.6

Added by PixelDrift.NET Support about 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When following the Katello 2.1 install procedure for CentOS 6.6 on the following page:
http://www.katello.org/docs/2.1/installation/index.html

The install process fails with the following error when running 'katello-installer' (with no flags)
[root@katello /root]# katello-installer
/Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
/Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
/Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
/Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[<hostname removed>]: Could not evaluate: 500 Internal Server Error
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[<hostname removed>]: Failed to call refresh: 500 Internal Server Error
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[<hostname removed>]: 500 Internal Server Error
Installing Done [100%] [.......................................................................................................................................]
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/katello-installer/katello-installer.log

When looking at the log the first error is:
[ WARN 2015-03-28 17:23:25 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: An error has occurred, this and all later migrations canceled:
[ WARN 2015-03-28 17:23:25 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns:
[ WARN 2015-03-28 17:23:25 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: PGError: ERROR: column reference "id" is ambiguous
[ WARN 2015-03-28 17:23:25 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: LINE 1: SELECT id FROM "discovery_attribute_sets" INNER JOIN "hosts"...
[ WARN 2015-03-28 17:23:25 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: ^
[ WARN 2015-03-28 17:23:25 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: : SELECT id FROM "discovery_attribute_sets" INNER JOIN "hosts" ON "hosts"."id" = "discovery_attribute_sets"."host_id" WHERE "hosts"."managed" = 't'
[ WARN 2015-03-28 17:23:25 main] /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns:

This is using a vanilla CentOS 6.6 image following the procedure. The only exception to the procedure is that 'yum downgrade puppet-3.7.4' was run after 'yum install katello' to resolve the Puppet 3.7.5 issue which has already been raised in the bug tracker.


Related issues

Is duplicate of Discovery - Bug #9912: 'foreman-rake db:migrate' fails with errorClosed2015-03-26

History

#1 Updated by PixelDrift.NET Support about 7 years ago

Adding a note that the 2.2 install procedure works as expected (same server, same CentOS 6.6 base image etc.)
http://www.katello.org/docs/2.2/installation/index.html

#2 Updated by Anonymous about 7 years ago

This is probably a duplicate of #9912. Please try downgrading foreman_discovery 2.0.1 to 2.0.0.

#3 Updated by Eric Helms about 7 years ago

  • Status changed from New to Duplicate
  • Triaged changed from No to Yes

#4 Updated by Eric Helms about 7 years ago

  • Is duplicate of Bug #9912: 'foreman-rake db:migrate' fails with error added

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF