Project

General

Profile

Feature #9945

Add vlan kernel command line params to configure primary interface VLAN

Added by Lukas Zapletal over 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Image
Target version:
-
Difficulty:
medium
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Add VLAN support for primary interface (the one it was PXE booted from or which was selected on the NIC screen).

For PXE mode discovery, new kernel option can be implemented: fdi.vlan.primary defining VLAN ID for primary (provisioning) interface. This is the interface it was PXE-booted from.

For secondary interfaces, VLAN will not be implemented. Please send comments if you want this to be implemented and how.

For PXE-less mode, new field will be added on the NIC selection dialog which will allow to define VLAN for the primary interface.

For more info: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Networking_Guide/sec-Configure_802_1Q_VLAN_Tagging_Using_the_Command_Line.html


Related issues

Related to Discovery - Feature #9943: Kernel param to override PEERDNS and DEFROUTERejected2015-03-30
Related to Discovery - Bug #20128: Increase timeout for nmcli and introduce fdi.nmwait kernel optionClosed2017-06-28
Is duplicate of Discovery - Feature #10835: Add support for VLAN ID into the imageDuplicate2015-06-16

Associated revisions

Revision 11ba0ae5 (diff)
Added by Lukas Zapletal about 5 years ago

Fixes #9945 - add VLAN support for primary interface

History

#1 Updated by Lukas Zapletal over 6 years ago

  • Related to Feature #9943: Kernel param to override PEERDNS and DEFROUTE added

#2 Updated by Lukas Zapletal over 6 years ago

The problem with kernel parameter is that you can only apply it for ALL discovered nodes on ALL networks as the template is generic. Once we have @subnet available in the discovery template, we can acquire the VLAN ID from there so this will work even automatic.

#3 Updated by Lukas Zapletal over 6 years ago

  • Is duplicate of Feature #10835: Add support for VLAN ID into the image added

#4 Updated by Lukas Zapletal over 5 years ago

  • Tracker changed from Bug to Feature
  • Description updated (diff)

#5 Updated by Lukas Zapletal over 5 years ago

  • Subject changed from Add vlan kernel command line params to configure VLAN interfaces to Add vlan kernel command line params to configure primary interface VLAN

Let's just configure primary interface VLAN in this ticket. I don't think it makes sense to do for secondary ones.

#6 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Lukas Zapletal
  • Pull request https://github.com/theforeman/foreman-discovery-image/pull/76 added

#7 Updated by Lukas Zapletal about 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Lukas Zapletal over 4 years ago

  • Related to Bug #20128: Increase timeout for nmcli and introduce fdi.nmwait kernel option added

Also available in: Atom PDF