Project

General

Profile

Bug #9990

Foreman_smartproxy fails to evalute with "couldn't find HOME environment"

Added by Xavier L over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Debian/Ubuntu
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When runnign Puppet agent manually, everything works fine. However, when running Puppet as a service, the Foreman_smartproxy type fails with:

puppet-agent[1747]: (/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[smart-proxy.fqdn]) Could not evaluate: couldn't find HOME environment -- expanding `~'

I'm running on Ubuntu 14.04.

Drilling down, it seems the issue is that foreman-cli requires the distro-packaged version of apipie-bindings, which is 0.0.8, the required version should be 0.0.9, as per issue #7063.

History

#1 Updated by Xavier L over 4 years ago

Actually the puppet foreman_proxy module requires the ruby-apipie-bindings package as well (https://github.com/theforeman/puppet-foreman_proxy/blob/master/manifests/install.pp).

#2 Updated by Xavier L over 4 years ago

Looking at http://deb.theforeman.org/pool/trusty/1.7/r/ruby-apipie-bindings/, it seems that the foreman packaged version (for foreman 1.7) is 0.0.8. Removing the module and installing the library from gem (gem install apipie-bindings) seems to clear the error, but the packaged version is installed on the next run, so the errors start again when the puppet agent is restarted.

#3 Updated by Michael Moll over 4 years ago

Could you try it with all packages from the 1.7 repos but apipie-bindings from the 1.8 repo on a clean system?

#4 Updated by Xavier L over 4 years ago

I manually installed ruby-apipie-bindings from 1.8 (wget http://deb.theforeman.org/pool/trusty/1.8/r/ruby-apipie-bindings/ruby-apipie-bindings_0.0.11-1_all.deb && dpkg -i ruby-apipie-bindings_0.0.11-1_all.deb). The errors cleaned-up and puppet is not trying to downgrade ruby-apipie-bindings to 0.0.8. So I guess that it's a valid workaround, but a real solution would be to release 0.0.8-2 (patched with https://github.com/Apipie/apipie-bindings/pull/14) or 0.0.9 to all the supported versions with 0.0.8.

#5 Updated by Xavier L over 4 years ago

This issue might need to get moved to a different project.

#6 Updated by Dominic Cleal over 4 years ago

  • Project changed from Foreman to Packaging
  • Category set to Debian/Ubuntu

Hm, seems to have been an oversight that we have apipie-bindings 0.0.8 in the deb repos and 0.0.10 in the RPMs, which it should be. I think the Hammer version are all the same, so updating it in 1.7 shouldn't cause an issue.

#7 Updated by Michael Moll over 4 years ago

  • Assignee set to Michael Moll

#8 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/612 added
  • Pull request deleted ()

#9 Updated by Dominic Cleal over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
  • Legacy Backlogs Release (now unused) set to 40

Package built, will be included in the next 1.7 release.

Also available in: Atom PDF