Bug #15176

Updated by Dominic Cleal about 6 years ago

The older version of Bundler used on Ubuntu 14.04 is failing to find a compatible version of fog-google due to the two slightly different requirements in bundler.d/gce.rb bundler.d/fog.rb and fog's gemspec:

08:38:16 /usr/bin/ruby2.0 /usr/bin/bundle pack --all
08:38:18 Fetching gem metadata from
08:38:31 Fetching gem metadata from
08:38:32 Resolving dependencies................
08:38:33 Bundler could not find compatible versions for gem "fog-google":
08:38:33 In Gemfile:
08:38:33 fog (= 1.38.0) ruby depends on
08:38:33 fog-google (<= 0.1.0) ruby
08:38:33 fog-google (0.3.2)

The bundler.d/gce.rb bundler.d/fog.rb specification should just mirror fog's for now for consistency. When fog changes it and we update fog, bundler.d/gce.rb bundler.d/fog.rb can be updated in sync.