Bug #17410

Rerun a job invocation loses the effective user

Added by Adam Ruzicka 7 months ago. Updated 24 days ago.

Status:Closed
Priority:Normal
Assigned To:Ivan Necas
Category:-
Target version:Foreman - Team Ivan Iteration 13
Difficulty: Pull request:https://github.com/theforeman/foreman_remote_execution/pull/241
Bugzilla link:1386208
Story points-
Velocity based estimate-
Releaseforeman_remote_execution 1.3.1Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1386208

Description of problem:
the effective user field is not included when a job is being rerun.
This is even more tricky, because it is not directly visible from the the new job invocation page because the effective user is hidden in the advanced fields that are by default collapsed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run a job template with effective user root
2. Rerun the job template
3.

Actual results:
The rerun of job template does not run with effective user root

Expected results:
The rerun job template runs with effective user root

Additional info:

Associated revisions

Revision c77cf860
Added by Ivan Necas 2 months ago

Fixes #17410 - effective user from job invocation on rerun

It also fixes issue with keeping effective user value when the form is
re-rendered.

History

#1 Updated by Adam Ruzicka 7 months ago

  • Target version set to Team Ivan backlog

#2 Updated by The Foreman Bot 2 months ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Ivan Necas
  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/241 added

#3 Updated by Ivan Necas 2 months ago

  • Target version changed from Team Ivan backlog to Team Ivan Iteration 13

#4 Updated by Ivan Necas 2 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Ivan Necas 24 days ago

  • Release set to foreman_remote_execution 1.3.1

Also available in: Atom PDF