Bug #6495

Unable to provision on RHEV 3.3 via templates

Added by Lukas Zapletal almost 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Lukas Zapletal
Category:Compute resources
Target version:Sprint 27
Difficulty: Bugzilla link:1112227
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.6.0Release relationshipAuto

Description

As reported by Martin Korbel in https://bugzilla.redhat.com/show_bug.cgi?id=1112227

Description of problem:
We cannot create new guest from the RHEV template image. We get this error message "Unable to save
Failed to create a compute RHEV-resource (RHEV) instance rhev20.test.example.com: Cannot add VM. Cannot set single display device to non Linux operating system."

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140618.0

How reproducible:
100%

Steps to Reproduce:
1. We have got Sat6 with RHEV compute resource. In this RHEV, we have got prepared the template (RHEL6, what was prepared using by this manual https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html/Administration_Guide/Sealing_a_Linux_Virtual_Machine_for_Deployment_as_a_Template_using_sys-unconfig.html)
2. Create new image ("infrastructure" > "Compute resources" > our RHEV resource > "Images" > "New Image").
Name: myTemplateRHEL6.5
Operatingsystem: RHEL Server 6.5
Architecture: x86_64
Username: root
Password: xxx
Image: <choose our RHEV template>
Press "submit".
3. We open "Kickstart default finish" in "Hosts" > "Provisioning Templates" and Add association with "RHEL Server 6.5".
4. We open "RHEL Server 6.5" in "Hosts" > "Operating systems" and in the Templates tab, we select
finish: "Kickstart default finish"
5. We try to create new guest from template. Open "Hosts" > "New Host"
Host
----------------------------------
Name: something
Deploy on: RHEV
Lifecycle environment: <select one>
Content view: <select one>

Network
----------------------------------
Domain: <selct one>
Subnet: <selct one>

Operating System
----------------------------------
Architecture: x86_64
Operating system: RHEL Server 6.5
Provisioning Method: Image Based
Image: myTemplateRHEL6.5
press "Resolve" button and we get "finish Template - Kickstart default finish"

6. Press "Submit" button. We get this error message "Unable to save
Failed to create a compute RHEV-resource (RHEV) instance rhev20.test.example.com: Cannot add VM. Cannot set single display device to non Linux operating system."
Logs are in the attachment first.txt (Attachment 911396 [details]).

7. We change nothing and press "Submit" button again.
At first, all look like good, but then we can detected, Sat6 created new guest without HDD.
Logs are in the attachment second.txt (Attachment 911397 [details]).

Actual results:
impossible create new guests from template image.


Related issues

Related to Foreman - Bug #5581: oVirt image based deployment does not create a disk New 05/06/2014

History

#1 Updated by Lukas Zapletal almost 4 years ago

  • Bugzilla link set to 1112227

Upstream bug for discussion filed:

https://github.com/abenari/rbovirt/issues/39

#2 Updated by Lukas Zapletal almost 4 years ago

When I remove the whole os XML element from the request, it works just fine. It looks like unassigned is no longer an option in RHEV/oVirt.

#3 Updated by Lukas Zapletal almost 4 years ago

  • Related to Bug #5581: oVirt image based deployment does not create a disk added

#4 Updated by Lukas Zapletal almost 4 years ago

Confirmed, the change in rbovirt is to remove os element when template element is present upon creating new VM.

#5 Updated by Dominic Cleal almost 4 years ago

  • Target version set to Sprint 25

#6 Updated by Dmitri Dolguikh almost 4 years ago

  • Target version changed from Sprint 25 to Sprint 26

#8 Updated by Dmitri Dolguikh over 3 years ago

  • Target version changed from Sprint 26 to Sprint 27

#9 Updated by Lukas Zapletal over 3 years ago

Patch accepted and fixed in 0.0.29.

Do I need to raise another issue for version bump Dominic?

#10 Updated by Dominic Cleal over 3 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100
  • Release set to 1.6.0

Nah, it's fine, our RPMs are already updated and debs will get it on the next build. Thanks Lukas!

Also available in: Atom PDF