Project

General

Profile

Bug #10087

Deploying vmware from template ignores nic_type (E1000 or vmxnet3) setting, and configures using E1000

Added by Francois Herbert over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Compute resources - VMware
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The fog vm_clone method utilises the variable "options['nic_type']" to set the nic type.
Checking app/models/compute_resources/foreman/model/vmware.rb, nic_type isn't passed to fog in the clone_vm method.


Related issues

Related to Foreman - Bug #6348: Provision host from image in VMware: wrong NIC typeDuplicate2014-06-23

Associated revisions

Revision f25e9797 (diff)
Added by Francois Herbert over 6 years ago

fixes #10087 - Pass nic_type to vm_clone

Revision 37ff1b67 (diff)
Added by Francois Herbert over 6 years ago

fixes #10087 - Pass nic_type to vm_clone

(cherry picked from commit f25e9797d6ae1e2dfebf268934ffd7d17536efbf)

History

#1 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2290 added
  • Pull request deleted ()

#2 Updated by Dominic Cleal over 6 years ago

  • Legacy Backlogs Release (now unused) deleted (35)

#3 Updated by Anonymous over 6 years ago

  • Related to Bug #6348: Provision host from image in VMware: wrong NIC type added

#4 Updated by Anonymous over 6 years ago

is this a duplicate of #6348?

#5 Updated by Francois Herbert over 6 years ago

Yes, it looks like it is a duplicate of #6348

#6 Updated by Dominic Cleal over 6 years ago

  • Legacy Backlogs Release (now unused) set to 28

#7 Updated by Anonymous over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF