Project

General

Profile

Bug #11021

PUT /api/v2/config_templates/:id returns an incomplete set of attributes

Added by Alon Goldboim about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1234973
Description of problem:
A config template has at least the following attributes:

  • audit_comment
  • id
  • locked
  • name
  • operatingsystem
  • organization
  • snippet
  • template
  • template_combinations
  • template_kind

When one updates a config template, the following attributes are returned:

  • created_at
  • default
  • id
  • locked
  • name
  • snippet
  • template
  • template_kind_id
  • updated_at
  • vendor

The following attributes are missing from the response:

  • audit_comment
  • operatingsystem
  • organization
  • template_combinations

Version-Release number of selected component (if applicable):
Satellite 6.1.0. Foreman-debug is attached.

How reproducible:
100%

Steps to Reproduce:
1. Issue HTTP PUT request to https://sat.example.com/api/v2/config_templates/:id
2. Capture the response. Examine the JSON payload and discover that several attributes are not mentioned.
3.

Actual results:
See "Description of problem" section.

Expected results:
See "Description of problem" section.

Additional info:


Related issues

Is duplicate of Foreman - Bug #10356: POST and PUT should use RABL templates for the response.Closed2015-05-04

History

#1 Updated by Dominic Cleal about 6 years ago

  • Is duplicate of Bug #10356: POST and PUT should use RABL templates for the response. added

#2 Updated by Dominic Cleal about 6 years ago

  • Status changed from New to Duplicate

This also looks identical to the other bug I marked as a dupe...

Also available in: Atom PDF