Project

General

Profile

Bug #11876

Regression with enabling Satellite Tools repository found while using upstream community build

Added by Mike McCune over 3 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1264192
Description of problem:

While using the upstream (community) build to test a few issues, I noticed that enabling the "Red Hat Satellite Tools 6.1 for RHEL 7 Server RPMs x86_64" repo set using the web ui failed with the following error:

["releasever"] cannot be specified for Red Hat Satellite Tools 6.1 (for RHEL 7 Server) (RPMs) as that information is not substituable in /content/dist/rhel/server/7/7Server/$basearch/sat-tools/6.1/os

Partha has narrowed down the cause which points to the following commit:

https://github.com/Katello/katello/commit/70f91b26dc04765f3b9c9cd14d12996ddace79ec

I'd like to ask that the commit mentioned above either be reverted or corrected, as it seems that the UI is passing a releasever = "" parameter and it shouldn't.

Version-Release number of selected component (if applicable):

Nightly (community) build

How reproducible:

Steps to Reproduce:
1. Enable the "Red Hat Satellite Tools 6.1 for RHEL 7 Server RPMs x86_64" repo set using the web ui
2.
3.

Actual results:

Error is displayed in the ui

Expected results:

Additional info:

Associated revisions

Revision 92f120a7 (diff)
Added by Partha Aji over 3 years ago

Fixes #11876 - Enable non basearch/releasever repos

The UI code after commit 70f91b26dc04765f3b9c9cd14d12996ddace79ec sent releasever
and basearch info to the controller as empty values for repos that didnt need this information.
This caused the controller to complain that bad substitutions were given to it.
This commit fixes that issue by not sending that information if they are
not needed.

Revision bc30192a
Added by Partha Aji over 3 years ago

Merge pull request #5490 from parthaa/enablement

Fixes #11876 - Enable non basearch/releasever repos

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5490 added
  • Pull request deleted ()

#2 Updated by Partha Aji over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 70
  • Triaged changed from No to Yes

Also available in: Atom PDF