Project

General

Profile

Bug #13664

Error 500 when a host informs the foreman it is built but foreman can not send mails

Added by Julien Pivotto almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
E-Mail
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When the foreman email is not properly configured, and a host is provisioned, it gets a 500 error when informing Foreman that it is built.

Attached the production.log in this ticket.

In the kickstart logs:

Informing Foreman that we are built
--2016-02-11 10:57:40--  http://172.22.110.154/unattended/built?token=fgcfa081-a398-4333-b351-d3af03c0f3921
Connecting to 172.22.110.154:80... connected.
HTTP request sent, awaiting response... 500 Internal Server Error
2016-02-11 10:57:42 ERROR 500: Internal Server Error.

Still the host is marked as built, as expected.

Expected behavior:
It logs in production.log that it can not send the email but returns 200. I do not want my host to be rebuild in a loop just because email can not be sent.

production.log production.log 14.9 KB Julien Pivotto, 02/11/2016 05:12 AM

Associated revisions

Revision a90e4f2f (diff)
Added by Shlomi Zadok almost 4 years ago

Fixes #13664 - rescue smtp errors if mail failed on host built

History

#1 Updated by Dominic Cleal almost 4 years ago

  • Category set to E-Mail

#2 Updated by Julien Pivotto almost 4 years ago

  • Description updated (diff)

#3 Updated by Julien Pivotto almost 4 years ago

  • Description updated (diff)

#4 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Shlomi Zadok
  • Pull request https://github.com/theforeman/foreman/pull/3176 added

#5 Updated by Shlomi Zadok almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 71

Also available in: Atom PDF