Project

General

Profile

Bug #13684

yum-config-manager is not available on RHEL 5

Added by Otavio Piske over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Templates
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I am trying to provision some RHEL 5 VMs and it has errors during the post install phase.

Steps to reproduce:
- configure the environments to subscribe to Red Hat Network.
- provision a VM for RHEL 5.

Result:
The install.post.log will contain an error: "line 100: yum-config-manager: command not found"

The root cause of the error seems to be related to the unavailability of yum-config-manager for RHEL 5 as described here: https://access.redhat.com/solutions/265523.

Associated revisions

Revision 1bb9baae (diff)
Added by Otavio Rodolfo Piske over 3 years ago

fixes #13684 - yum-config-manager is not available on RHEL 5

closes GH-237

History

#1 Updated by Dominic Cleal over 3 years ago

  • Category set to Templates

Looks like this is specifically the "redhat_register" snippet.

The source for this is at https://github.com/theforeman/community-templates/blob/develop/snippets/redhat_register.erb if you have a patch you can share, you can send fixes through the GitHub UI and it'll be included in the next version of Foreman.

#2 Updated by Otavio Piske over 3 years ago

Thanks, I have a patch for this. I will send it through the GitHub.

#3 Updated by Michael Moll over 3 years ago

  • Assignee set to Otavio Piske
  • Pull request https://github.com/theforeman/community-templates/pull/237 added

#4 Updated by Michael Moll over 3 years ago

  • Legacy Backlogs Release (now unused) set to 123

#5 Updated by Michael Moll over 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF