Project

General

Profile

Bug #13995

hammer sc-params --hostgroup option do not work with --hostgroup-id option. Error "missing param 'hostgroup_id' in parameters"

Added by Brad Buckingham over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1303653
Description of problem:
With hammer CLI trying to get sc-params details of hostgroup fails with error "missing param hostgroup_id' in parameters" when trying using options --hostgroup and --hostgroup-id.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli-0.1.4.13-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to get sc-params of hostgroup using hammer CLI.

  1. hammer hostgroup sc-params --hostgroup <hostgroup-name> --hostgroup-id <hostgroup-id>
    missing param 'hostgroup_id' in parameters

2. --hostgroup-id option do not work with --name too.

  1. hammer hostgroup sc-params --name <hostgroup-name> --hostgroup-id <hostgroup-id>
    Error: 400 Bad Request

3. It do not work alone too as like --id option.

  1. hammer hostgroup sc-params --hostgroup-id <hostgroup-id>
    missing param 'hostgroup_id' in parameters

Actual results:
missing param 'hostgroup_id' in parameters
Error: 400 Bad Request

Expected results:
It should work as like --id option.

Additional info:

History

#1 Updated by Dominic Cleal over 4 years ago

  • Status changed from New to Rejected

Seems to work fine, I can't reproduce any of those problems. The version of Hammer listed is very old, please test on a current release.

$ hammer hostgroup sc-params --hostgroup test
---|-----------|---------------|----------|-------------
ID | PARAMETER | DEFAULT VALUE | OVERRIDE | PUPPET CLASS
---|-----------|---------------|----------|-------------
$ hammer hostgroup sc-params --hostgroup test --hostgroup-id 1
---|-----------|---------------|----------|-------------
ID | PARAMETER | DEFAULT VALUE | OVERRIDE | PUPPET CLASS
---|-----------|---------------|----------|-------------
$ hammer hostgroup sc-params --name test --hostgroup-id 1
Error: Unrecognised option '--name'

See: 'hammer hostgroup sc-params --help'
$ hammer hostgroup sc-params --hostgroup-id 1
---|-----------|---------------|----------|-------------
ID | PARAMETER | DEFAULT VALUE | OVERRIDE | PUPPET CLASS
---|-----------|---------------|----------|-------------

Also available in: Atom PDF