Project

General

Profile

Actions

Bug #14814

closed

VM provisioning using Forman

Added by Mostafa Yasin almost 8 years ago. Updated almost 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Greetings,

Please be informed that I installed Foreman Version 1.8.0 on CentOS Version 7.1 and I have VMware ESX version 6.
I successfully have registered ESX to Foreman by creating "Compute resources" and then "Compute profiles"

When I try to provision VMs, I get this error "Unable to save mac value is blank!"

Please, I need to provision VMs in ESX using foreman but I don't have Vcenter.

Is there any work around for this issue?.

Regards,
Mostafa


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Bug #8528: Provisioning on a non-clustered ESXiDuplicate11/27/2014Actions
Actions #1

Updated by Dominic Cleal almost 8 years ago

  • Is duplicate of Bug #8528: Provisioning on a non-clustered ESXi added
Actions #2

Updated by Dominic Cleal almost 8 years ago

  • Status changed from New to Duplicate

vSphere is required for Foreman's VMware integration, see http://theforeman.org/manuals/1.11/index.html#5.2.9VMwareNotes, and existing issues #8528 and #1945.

Actions #3

Updated by Mostafa Yasin almost 8 years ago

Hi Dominic,

Thank you so much for your help. I have read your message, but Unfortunately i didn't understand what should i do because I am new in the Foreman technology but I would like to use it in our environment.

Could you please simplify, what should i do to solve the issue of "Unable to save mac value is blank!" ?

Please let me know, Is it mandatory to have Vcenter or these is a work around to solve this issue?

Thank you so much.
Regards,

Actions #4

Updated by Dominic Cleal almost 8 years ago

Mostafa Yasin wrote:

Please let me know, Is it mandatory to have Vcenter or these is a work around to solve this issue?

It is mandatory for the VMware support. You should get it, or create the VMs manually, copy the MAC address down and then add them to Foreman as "bare metal" (not using VMware support) with the MAC addresses.

Actions #5

Updated by Mostafa Yasin almost 8 years ago

Thank you so much Dominic. Now I understood.

Actions

Also available in: Atom PDF