Project

General

Profile

Bug #14815

Error Running Katello-installer

Added by Martin Juhl about 3 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hi

After following the installation guide to add the needed repositories and installing katello, I get an error running katello-installer:

[root@starkiller ~]# katello-installer
Redirecting to /bin/systemctl stop httpd.service
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[starkiller.outerrim.lan]: Could not evaluate: Proxy starkiller.outerrim.lan cannot be registered (Could not load data from https://starkiller.outerrim.lan
Installing Done [100%] [......................................................................................]
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/katello-installer/katello-installer.log

I have also tried running katello-installer --reset, with the same result ...

In the postgresql logs I see:

STATEMENT: SELECT a.attname, format_type(a.atttypid, a.atttypmod), d.adsrc, a.attnotnull
FROM pg_attribute a LEFT JOIN pg_attrdef d
ON a.attrelid = d.adrelid AND a.attnum = d.adnum
WHERE a.attrelid = '"template_kinds"'::regclass
AND a.attnum > 0 AND NOT a.attisdropped
ORDER BY a.attnum

ERROR: relation "settings" does not exist at character 245
STATEMENT: SELECT a.attname, format_type(a.atttypid, a.atttypmod), d.adsrc, a.attnotnull
FROM pg_attribute a LEFT JOIN pg_attrdef d
ON a.attrelid = d.adrelid AND a.attnum = d.adnum
WHERE a.attrelid = '"settings"'::regclass
AND a.attnum > 0 AND NOT a.attisdropped
ORDER BY a.attnum

ERROR: relation "settings" does not exist at character 245
STATEMENT: SELECT a.attname, format_type(a.atttypid, a.atttypmod), d.adsrc, a.attnotnull
FROM pg_attribute a LEFT JOIN pg_attrdef d
ON a.attrelid = d.adrelid AND a.attnum = d.adnum
WHERE a.attrelid = '"settings"'::regclass
AND a.attnum > 0 AND NOT a.attisdropped
ORDER BY a.attnum

ERROR: relation "template_kinds" does not exist at character 245
STATEMENT: SELECT a.attname, format_type(a.atttypid, a.atttypmod), d.adsrc, a.attnotnull
FROM pg_attribute a LEFT JOIN pg_attrdef d
ON a.attrelid = d.adrelid AND a.attnum = d.adnum
WHERE a.attrelid = '"template_kinds"'::regclass
AND a.attnum > 0 AND NOT a.attisdropped
ORDER BY a.attnum

ERROR: relation "gb_event" does not exist at character 36
STATEMENT: select count(this_.id) as y0_ from gb_event this_ where this_.messageId=$1 and this_.messageId<>$2
ERROR: relation "gb_event" does not exist at character 36
STATEMENT: select count(this_.id) as y0_ from gb_event this_ where this_.messageId=$1 and this_.messageId<>$2
LOG: received fast shutdown request

Please advice..


Related issues

Is duplicate of SELinux - Bug #14811: Passenger paths changed once again (RHEL7)Closed2016-04-26

History

#1 Updated by Eric Helms about 3 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 150 to 114

#2 Updated by Eric Helms about 3 years ago

  • Is duplicate of Bug #14811: Passenger paths changed once again (RHEL7) added

Also available in: Atom PDF