Project

General

Profile

Bug #1502

A subnet without TFTP set makes foreman unable to set a host in build.

Added by Ashley Penney over 7 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We have a situation where we need to set hosts to build but we cannot use DHCP/TFTP and instead use a boot.iso to pass the params into boot: by hand. We do however require the kickstart from foreman. As it stands if you put a machine in a subnet that has no TFTP assigned Foreman will attempt to write the TFTP stuff locally and fail to set build:

Processing HostsController#setBuild (for 10.45.62.4 at 2012-02-23 18:20:03) [GET]
Parameters: {"action"=>"setBuild", "id"=>"per5-puppet-test.usa.net", "controller"=>"hosts"}
DEPRECATION WARNING* Managing TFTP without a smart-proxy will not be supported in the next release
TFTP Failed: Permission denied - RedHat-5.7-x86_64 or /usr/share/foreman//01-00-0c-29-dd-10-0b
Failed to save:
Redirected to https://foreman.sys.perimeterusa.com/hosts/per5-puppet-test.usa.net
Completed in 15ms (DB: 9) | 302 Found [https://foreman.sys.perimeterusa.com/hosts/per5-puppet-test.usa.net/setBuild]

If tftp is not set then don't try to write any TFTP stuff. :)

History

#1 Updated by Ashley Penney over 7 years ago

Looks like a duplicate of http://www.theforeman.org/issues/1376 - didn't spot it when looking earlier, sorry!

#2 Updated by Benjamin Papillon about 6 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF