Project

General

Profile

Feature #1524

Add more attributes to JSON index

Added by Corey Osman about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
API
Target version:
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Currently foreman only returns a arrray of hostnames as the default index action for json output.

I would like to add more host attributes so I don't have to make more calls to foreman in future requests.

This will break versions of remoteadmin prior to upcoming 0.6 version and may cause issues with foreman CLI but I think its a better solution in the long run.

I am adding the following attributes:

id, hostgroup_id, puppet_status.

It will be easy to add more attributes later.


Related issues

Is duplicate of Foreman - Bug #875: Non consistent behaviour of GET APIsDuplicate2011-05-03

Associated revisions

Revision b16f321a (diff)
Added by Corey Osman about 7 years ago

fixes #1524 Add more attributes to JSON host index

Signed-off-by: Corey Osman <>

Revision 0db5df0b (diff)
Added by Ohad Levy about 7 years ago

refs #1524 - fixed incorrect syntax

History

#1 Updated by Corey Osman about 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF