Project

General

Profile

Bug #16099

Running smart-proxy in daemon mode results in missed inotify events on isc leases file

Added by Dmitri Dolguikh almost 3 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Category:
DHCP
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Related issues

Related to Foreman - Bug #16093: DHCP deletion is scheduled twice on MAC changeNew2016-08-12

Associated revisions

Revision 350b4cf7 (diff)
Added by Dmitri Dolguikh almost 3 years ago

Fixes #16099 - in daemon mode module threads continue to execute

This also fixes the issue with missed isc lease file updates.

History

#1 Updated by Dmitri Dolguikh almost 3 years ago

  • Subject changed from Smart-proxy running in daemon mode results in missed inotify events on isc leases file to Running smart-proxy in daemon mode results in missed inotify events on isc leases file

#2 Updated by Dmitri Dolguikh almost 3 years ago

  • Related to Bug #16093: DHCP deletion is scheduled twice on MAC change added

#3 Updated by Dmitri Dolguikh almost 3 years ago

A possible fix is to do forking before all initialization/startup code.

#4 Updated by Dmitri Dolguikh almost 3 years ago

The cause of the problem is the monitoring thread started at https://github.com/theforeman/smart-proxy/blob/develop/modules/dhcp_isc/inotify_leases_file_observer.rb#L37 is terminated when the parent fork exits.

#5 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Dmitri Dolguikh
  • Pull request https://github.com/theforeman/smart-proxy/pull/453 added

#6 Updated by Dominic Cleal almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 160

#7 Updated by Ivan Necas almost 3 years ago

  • Target version set to 1.6.1

#8 Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF