Project

General

Profile

Bug #16141

fast_gettext 1.2.0 isn't compatible with ruby 2.0

Added by Tomáš Strachota almost 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Foreman commands (obsolete)
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

fast_gettext 1.2 dropped support for ruby <= 2.0 which prevents bundle install from finishing successfully on 2.0
This is currently blocking our Jenkins tests.

Since this PR https://github.com/theforeman/hammer-cli/pull/198 contains backwards compatibility layer for older versions of fast_gettext, it's fine to just pin it to 1.1.0 for ruby 2.0

Associated revisions

Revision bfad7da9 (diff)
Added by Tomas Strachota almost 4 years ago

Fixes #16141 - pin fast_gettext to < 1.1.0 for ruby < 2.1 (#257)

fast_gettext 1.2.0 drops support for ruby 2.0 and below

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/257 added

#2 Updated by Anonymous almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF