Project

General

Profile

Bug #16340

Errata install to content host completes stopped/success but host does not get updated

Added by Michael Palmer about 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Category:
Errata Management
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

katello-agent 2.5.0-3
katello 3.0

When i apply errata to a content host the task completes without error, stopped/success. However, the actual host does not get updated. Yum update on the host shows the updates are ready to be installed before and after executing errata apply from katello. Attached file, content-host_messages.log, is /var/log/messages of the content host. It is from the point of restarting goferd, followed by applying errata.

DF output

---
pulp_tasks:
- exception:
task_type:
_href: "/pulp/api/v2/tasks/ca411660-a94f-4eea-b26b-ac1d45c5ac85/"
task_id: ca411660-a94f-4eea-b26b-ac1d45c5ac85
tags:
- pulp:consumer:1c32aa90-c0b9-47ab-8f66-026dfac4466d
- pulp:action:unit_install
finish_time: '2016-08-26T15:50:45Z'
_ns: task_status
start_time: '2016-08-26T15:50:43Z'
traceback:
spawned_tasks: []
progress_report: {}
queue: agent.dq
state: finished
worker_name: agent
result:
reboot:
scheduled: false
details: {}
details:
erratum:
details:
resolved: []
failed: []
deps: []
succeeded: true
succeeded: true
num_changes: 0
error:
_id:
"$oid": xxxxxxxxxxxxxxx
id: xxxxxxxxxxxxxxx
poll_attempts:
total: 5
failed: 0

content-host_messages.log content-host_messages.log 9.46 KB Message logs from restart of goferd through attempted install Michael Palmer, 08/26/2016 12:49 PM

History

#1 Updated by Justin Sherrill about 4 years ago

Sadly I suspect this is related to https://pulp.plan.io/issues/2217

#2 Updated by Justin Sherrill about 4 years ago

Michael,

The pulp bug i discovered seems to only affect certain errata that are very rare.

Which repo and which errata did you see this with?

#4 Updated by Justin Sherrill about 4 years ago

curious about this, on your katello server:

rpm -qa pulp

on your client:

rpm -qa | grep pulp

#5 Updated by Michael Palmer about 4 years ago

rpm -qa pulp did not get any results. I provided the pulp-server and pulp-katello versions.

On Katello server:
  • pulp-server-2.8.6-1.el7.noarch
  • pulp-katello-1.0-1.el7.noarch
On Katello Capsule:
  • pulp-server-2.8.6-1.el7.noarch
  • pulp-katello-1.0-1.el7.noarch
On client/Content hosts:
  • python-pulp-agent-lib-2.8.6-1.el7.noarch
  • python-pulp-common-2.8.6-1.el7.noarch
  • python-pulp-rpm-common-2.8.6-1.el7.noarch
  • python-isodate-0.5.0-4.pulp.el7.noarch
  • pulp-rpm-handlers-2.8.6-1.el7.noarch

#6 Updated by Michael Palmer about 4 years ago

These errata are also having the same issue.

ELBA-2016-3603
ELBA-2016-3604

#7 Updated by Justin Sherrill about 4 years ago

  • Assignee set to Justin Sherrill
  • Difficulty set to easy

#8 Updated by Eric Helms about 4 years ago

  • Status changed from New to Assigned

#9 Updated by Eric Helms about 4 years ago

Michael,

With 3.2 about to come out, would you be able to re-test on either 3.1 stable or 3.2 when it comes out?

#10 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

#11 Updated by Justin Sherrill almost 4 years ago

I synced oracle linux and tried on a couple errata:

ELSA-2016-1626
ELSA-2016-1626

and it seemed to work fine. This was with:

qpid-proton-c-0.14.0-1.el7.x86_64
qpid-cpp-server-1.35.0-1.el7.x86_64

#12 Updated by Justin Sherrill almost 4 years ago

  • Status changed from Assigned to Rejected

Closing this as I couldn't reproduce, if you can reproduce on 3.2 (with latest qpid from epel), please let us know.

Also available in: Atom PDF