Project

General

Profile

Bug #16536

Adding a global param / Associating a provisionning template with an OS -> Exception EOFError in Rack application object

Added by Thomas Saquet over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hello,

I work on a fresh Foreman 1.12.2 installation on Debian Jessie.

When I try to :
  • add a global parameter
  • associate a provisionning template with an OS

I have an error similar to the one described in issue #14918 :

Adding a global parameter :

==> /var/log/apache2/error.log <==
App 4422 stderr: [ 2016-09-13 09:27:36.1549 4447/0x000000018f6050(Worker 1) utils.rb:84 ]: *** Exception EOFError in Rack application object (bad content body) (process 4447, thread 0x000000018f6050(Worker 1)):
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:148:in `get_current_head_and_filename_and_content_type_and_name_and_body'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:59:in `block in parse'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:56:in `loop'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:56:in `parse'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart.rb:25:in `parse_multipart'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/request.rb:375:in `parse_multipart'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/request.rb:207:in `POST'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/methodoverride.rb:39:in `method_override_param'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/methodoverride.rb:27:in `method_override'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/methodoverride.rb:15:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/runtime.rb:18:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/activesupport-4.2.7.1/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/actionpack-4.2.7.1/lib/action_dispatch/middleware/static.rb:120:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/sendfile.rb:113:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/engine.rb:518:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/application.rb:165:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/railtie.rb:194:in `public_send'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/railtie.rb:194:in `method_missing'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/urlmap.rb:66:in `block in call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/urlmap.rb:50:in `each'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/urlmap.rb:50:in `call'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/rack/thread_handler_extension.rb:74:in `process_request'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:141:in `accept_and_process_next_request'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:109:in `main_loop'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler.rb:455:in `block (3 levels) in start_threads'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/logging-2.1.0/lib/logging/diagnostic_context.rb:450:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/logging-2.1.0/lib/logging/diagnostic_context.rb:450:in `block in create_with_logging_context'

==> /var/log/apache2/foreman-ssl_error_ssl.log <==
[Tue Sep 13 09:27:36.155168 2016] [core:error] [pid 4062:tid 139852431410944] [client 10.1.10.8:61839] End of script output before headers: common_parameters, referer: https://10.1.10.14/foreman/common_parameters

==> /var/log/apache2/error.log <==

==> /var/log/apache2/foreman-ssl_access_ssl.log <==
10.1.10.8 - - [13/Sep/2016:09:27:36 -0400] "POST /foreman/common_parameters HTTP/1.1" 500 531 "https://10.1.10.14/foreman/common_parameters" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko" 

Associating a provisionning model to an os :

==> /var/log/apache2/error.log <==
App 4422 stderr: [ 2016-09-13 10:22:22.3832 4447/0x000000018f6050(Worker 1) utils.rb:84 ]: *** Exception EOFError in Rack application object (bad content body) (process 4447, thread 0x000000018f6050(Worker 1)):
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:148:in `get_current_head_and_filename_and_content_type_and_name_and_body'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:59:in `block in parse'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:56:in `loop'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart/parser.rb:56:in `parse'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/multipart.rb:25:in `parse_multipart'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/request.rb:375:in `parse_multipart'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/request.rb:207:in `POST'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/methodoverride.rb:39:in `method_override_param'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/methodoverride.rb:27:in `method_override'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/methodoverride.rb:15:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/runtime.rb:18:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/activesupport-4.2.7.1/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/actionpack-4.2.7.1/lib/action_dispatch/middleware/static.rb:120:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/sendfile.rb:113:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/engine.rb:518:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/application.rb:165:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/railtie.rb:194:in `public_send'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/railties-4.2.7.1/lib/rails/railtie.rb:194:in `method_missing'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/urlmap.rb:66:in `block in call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/urlmap.rb:50:in `each'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/rack-1.6.4/lib/rack/urlmap.rb:50:in `call'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/rack/thread_handler_extension.rb:74:in `process_request'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:141:in `accept_and_process_next_request'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:109:in `main_loop'
App 4422 stderr:        from /usr/lib/ruby/vendor_ruby/phusion_passenger/request_handler.rb:455:in `block (3 levels) in start_threads'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/logging-2.1.0/lib/logging/diagnostic_context.rb:450:in `call'
App 4422 stderr:        from /usr/share/foreman/vendor/ruby/2.1.0/gems/logging-2.1.0/lib/logging/diagnostic_context.rb:450:in `block in create_with_logging_context'

==> /var/log/apache2/foreman-ssl_error_ssl.log <==
[Tue Sep 13 10:22:22.384837 2016] [core:error] [pid 4062:tid 139852540516096] [client 10.1.10.8:62195] End of script output before headers: templates, referer: https://10.1.10.14/foreman/templates/provisioning_templates?utf8=%E2%9C%93&search=preseed

==> /var/log/apache2/foreman-ssl_access_ssl.log <==
10.1.10.8 - - [13/Sep/2016:10:22:22 -0400] "POST /foreman/templates/provisioning_templates/34-Preseed%20default HTTP/1.1" 500 531 "https://10.1.10.14/foreman/templates/provisioning_templates?utf8=%E2%9C%93&search=preseed" "Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko" 

I do not have these problems on an instance updated from 1.9 -> 1.10 -> 1.11 -> 1.12.

It would be great if someone could help me :)

Thank you,
Regards
Thomas


Related issues

Is duplicate of Foreman - Bug #14346: New Template feature does not work with firefox 45.0New2016-03-24

History

#1 Updated by Dominic Cleal over 4 years ago

  • Is duplicate of Bug #14346: New Template feature does not work with firefox 45.0 added

#2 Updated by Dominic Cleal over 4 years ago

  • Status changed from New to Duplicate

The issue you linked to is a duplicate of #14346 which isn't yet resolved. Until it is, I don't think there's anything I can add here, sorry.

#3 Updated by Thomas Saquet over 4 years ago

Thank you for your answer.

I have a workaround for my first problem, I can have an hostgroup parameter.
For the second point, how can I use Foreman if I cannot set a provisionning template for my OS ? Do you have an idea about a workaround on that problem ?

If not, this could soon be a huge problem for us :)

Thank you in advance,
Thomas

Also available in: Atom PDF