Project

General

Profile

Bug #16688

It's impossible to use hammer or the API to set the installation source to a synced content (product)

Added by Simone Caldana about 4 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Katello version is 3.2.
The scenario is as follows
  1. a product is created pointing to a Centos repo
  2. Katello creates the corresponding installation media
  3. the installation media (as synced content) is associated to an hostgroup: this is only possible via the UI
  4. any new host created via hammer and using the aforementioned hostgroup requires a --medium parameter, or it will say
      Failed to generate PXELinux template : undefined method `path' for nil:NilClass
    
  5. by using the UI it is possible to create a host that uses the synced product as installation source. hammer host info show no difference between such a host and another created using the corresponding medium. The relevant difference is that while the host with synced content source draws the packages from the content source (in my case a capsule) the other one always refers to the URL, which points to the main katello instance.

Summarizing, the bugs are:
1. it's not possible to manage or point to a synced content as installation source
2. it's not possible to set a synced content as installation source using hammer or the api
3. the synced content set in the hostgroup is not correctly inherited by a host
4. it's not possible to create a host that uses the content source as installation media without using the UI.


Related issues

Is duplicate of Katello - Bug #16776: Kickstart repository not exposed on host group APIClosed2016-10-03

History

#1 Updated by Simone Caldana about 4 years ago

Katello version is 3.1, sorry

#2 Updated by Eric Helms about 4 years ago

  • Is duplicate of Bug #16776: Kickstart repository not exposed on host group API added

#3 Updated by Eric Helms about 4 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 162 to 166

Also available in: Atom PDF