Project

General

Profile

Bug #16825

katello-restore: Perform required files check before starting the restore

Added by Christine Fouant over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Backup & Restore
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1380905
Description of problem:
katello-restore: Perform required files check before starting the restore

Version-Release number of selected component (if applicable):
Satellite-6.1.10

How reproducible:
Always

Steps to Reproduce:
1. Get data export from an other satellite. I had the following files in /restore folder
01678184-01678184-config_files.tar.gz
01678184-01678184-elastic_data.tar.gz
01678184-01678184-mongo_data.tar.gz
01678184-01678184-pgsql_data.tar.gz
2. run katello-restore:
#katello-restore /restore
...
...
Restoring backend data
tar (child): elastic_data.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
tar: pulp_data.tar: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar (child): mongo_data.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
tar (child): pgsql_data.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
Done.
...
...

Actual results:
katello-restore failed since the tar file names aren't what the system expected

Expected results:
katello-restore should check for the tar file names before starting the restore process.

Additional info:

Associated revisions

Revision 0d033937 (diff)
Added by Christine Fouant over 5 years ago

fixes #16825 - verifies valid backup exists before attempting to restore (#303)

History

#1 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-packaging/pull/303 added

#2 Updated by Justin Sherrill over 5 years ago

  • Category set to Backup & Restore
  • Legacy Backlogs Release (now unused) set to 197
  • Difficulty set to medium

#3 Updated by Christine Fouant over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF