Project

General

Profile

Bug #17331

event_queue bombs with traceback on EL6

Added by Chris Roberts over 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem:
event queue on rhel 6 explodes with python traceback because '' are not used

Version-Release number of selected component (if applicable):

6.1 -> 6.2

How reproducible:

Steps to Reproduce:
1. install 6.1 on EL6
2. try to upgrade to 6.2
3. watch and enjoy with some popcorn

Actual results:

[root@sat61-rhel6 post]# qpid-stat -q --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 | grep :event | wc -l
Exception in thread Thread-1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
File "/usr/lib64/python2.6/threading.py", line 532, in __bootstrap_inner
File "/usr/lib64/python2.6/threading.py", line 484, in run
File "/usr/lib/python2.6/site-packages/qpid/selector.py", line 155, in run
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'time'

Expected results:
event_queue removed

Associated revisions

Revision 4f534ed9 (diff)
Added by Chris Roberts over 5 years ago

Fixes #17331 - supress el6 qpid-stat traceback (#435)

Fixes #17331 - supress el6 qpid-stat traceback

History

#1 Updated by Chris Roberts over 5 years ago

  • Assignee set to Chris Roberts

#2 Updated by Chris Roberts over 5 years ago

  • Bugzilla link set to 1394970

#3 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/435 added

#4 Updated by Chris Roberts over 5 years ago

Traceback happens randomly, not just on installer run. But this causes issues for upgrades where it shows the user something went wrong during the queue removal but in reality this is caused by qpid-stat but the queue did get removed ok

https://paste.fedoraproject.org/483909/40169014/

#5 Updated by Chris Roberts over 5 years ago

Each time I have been able to replicate the traceback the queue is removed. So this BZ is to supress the traceback during the installer run

#6 Updated by Chris Roberts over 5 years ago

  • Status changed from Ready For Testing to Resolved

Also available in: Atom PDF