Project

General

Profile

Bug #17643

capsule-installer: check for validity of --certs-tar file location before commencing

Added by Chris Roberts over 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from BZ:

Description of problem:
If the filename entered for --certs-tar is not correct, the installer will commence and eventually error out for confusing reasons. We should do some sanity checking to make sure the filename passed to --certs-tar is valid before starting install.

Version-Release number of selected component (if applicable):

Satellite-6.0.3-RHEL-6-20140702.0

How reproducible:

Steps to Reproduce:
1. On main instance, create cert for target capsule and copy to target
2. Attempt to install capsule, but use an incorrect string for the certs.tar file, i.e. cloud-qe-4.idm.lab.bos.redhat.com-certs.tra (note the typo)
3. View results

Actual results:
Process errors out and user has to dig pretty deep into the log to figure out why the install failed; it is not really clear that it is due to a bad value passed to --certs-tar

Expected results:
We should validate the value passed to --certs-tar before ever executing.

Associated revisions

Revision 58fa2a77 (diff)
Added by Chris Roberts over 5 years ago

Fixes #17643 - Add check to verify capsule tar (#448)

Fixes #17643 - Add check to verify capsule tar

History

#1 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/448 added

#2 Updated by Chris Roberts over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Chris Roberts over 5 years ago

  • Status changed from Closed to Resolved

Also available in: Atom PDF