Project

General

Profile

Bug #17929

Trying to delete a Puppet content view version throws the error " TypeError: Value (NilClass) '' is not any of: ForemanTasks::Concerns::ActionSubject"

Added by Justin Sherrill about 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1388618

Description of problem:

Trying to delete a Puppet content view version throws the error " TypeError: Value (NilClass) '' is not any of: ForemanTasks::Concerns::ActionSubject".

Version-Release number of selected component (if applicable):
Red Hat Satellite 6.2.2

How reproducible:
Usually happens with content views created prior the upgrade to 6.2. I was not able to reproduce it with a new content view after upgrading it.

During the troubleshoot this is the error we got:

passenger debug:
-------------------
[ 2016-10-24 16:11:49.9416 47968/7f2884bd4700 agents/HelperAgent/RequestHandler.h:1384 ]: [Client 20] Processed client data: consumed 4911 bytes
[ 2016-10-24 16:11:49.9417 47968/7f2884bd4700 agents/HelperAgent/RequestHandler.h:1362 ]: [Client 20] Processing client data: "{"id":38,"environment_ids":[],"content_view_version_ids":[110]}"
[ 2016-10-24 16:11:49.9417 47968/7f2886a9d700 Pool2/Implementation.cpp:1274 ]: [App 48122 stderr] [ 2016-10-24 16:11:49.9415 48336/0x00000007a043d8(Worker 1) request_handler/thread_handler.rb:130 ]: Accepted new request on socket main socket

foreman logs:
--------------------
2016-10-24 15:55:31 [app] [I] Started PUT "/katello/api/v2/content_views/38/remove?organization_id=1" for 10.10.58.68 at 2016-10-24 15:55:31 -0400
2016-10-24 15:55:31 [app] [D] Value for params[:environment_ids] was set to nil, because it was one of [], [null] or [null, null, ...]. Go to http://guides.rubyonrails.org/security.html#unsafe-query-generation for more information.
2016-10-24 15:55:31 [app] [I] Processing by Katello::Api::V2::ContentViewsController#remove as JSON
2016-10-24 15:55:31 [app] [I] Parameters: {"id"=>"38", "environment_ids"=>nil, "content_view_version_ids"=>[110], "organization_id"=>"1", "api_version"=>"v2", "content_view"=>{"id"=>"38"}}
2016-10-24 15:55:31 [app] [D] Setting current user thread-local variable to admin
2016-10-24 15:55:31 [foreman-tasks/action] [E] Value (NilClass) '' is not any of: ForemanTasks::Concerns::ActionSubject. (TypeError)

Actual results:
Does not delete the content view version

Expected results:
Delete the content view version

Additional info:

Associated revisions

Revision b2c0e756 (diff)
Added by Justin Sherrill about 2 years ago

Fixes #17929 - handle cvv deletion with missing puppet env

History

#1 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6523 added

#2 Updated by Justin Sherrill about 2 years ago

  • Target version set to 151

#3 Updated by Justin Sherrill about 2 years ago

  • Priority changed from High to Normal
  • Legacy Backlogs Release (now unused) set to 211

#4 Updated by Justin Sherrill about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF