Project

General

Profile

Bug #18495

undefined method `[]' for nil:NilClass - content view publishing and promoting

Added by Johannes Hirte over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I've updated a katello installation from 3.2 to 3.3-rc2 following this guide: https://theforeman.org/plugins/katello/3.3/upgrade/index.html

The update was smoothly. But now there is a bug with publishing/promoting of new versions of already existing content views. At 94% the process stopped in error state with the following error message:

NoMethodError: undefined method `[]' for nil:NilClass

Now I have the content view stuck in error state. I can't cancel the task or remove the version. A complete new content view, added after the update, doesn't has this problem.

Attaching the log when trying to resume the faulty task with hammer cli.

foreman-publish-error foreman-publish-error 58.1 KB Johannes Hirte, 02/14/2017 09:22 AM
foreman-debug-4WdUk.tar.xz foreman-debug-4WdUk.tar.xz 4.15 MB Johannes Hirte, 02/16/2017 02:45 AM

Related issues

Is duplicate of Katello - Bug #18793: Content Views Create/Promotion Fails with "undefined method '[]' for nil:NilClass (NoMethodError) Closed2017-03-03

History

#1 Updated by Dominic Cleal over 5 years ago

  • Project changed from Foreman to Katello

#2 Updated by Eric Helms over 5 years ago

  • Category set to Content Views
  • Legacy Backlogs Release (now unused) set to 219

Could you provide us with a foreman-debug so we can investigate this further?

#3 Updated by Johannes Hirte over 5 years ago

foreman-debug info added

#4 Updated by Eric Helms about 5 years ago

  • Status changed from New to Needs design

#5 Updated by Eric Helms about 5 years ago

  • Status changed from Needs design to Duplicate
  • Legacy Backlogs Release (now unused) changed from 219 to 166

#6 Updated by Eric Helms about 5 years ago

  • Is duplicate of Bug #18793: Content Views Create/Promotion Fails with "undefined method '[]' for nil:NilClass (NoMethodError) added

Also available in: Atom PDF