Project

General

Profile

Bug #18523

hammer cli : hostgroup info is not showing content-related fields

Added by Amit Upadhye over 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1313056

Description of problem:

Bug 1267629 raised the issue that content-related fields are not included as part of the API. This included fields such as the following:

"content_source_id": 1,
"content_source_name": "katello-centos7-devel",
"content_view_id": 1,
"content_view_name": "Default Organization View",
"lifecycle_environment_id": 1,
"lifecycle_environment_name": "Library",

That issue has since been addressed; however, the fields should also be visible from the hammer cli.

Version-Release number of selected component (if applicable):
Satellite 6.1 and prior.

How reproducible:
Always

Steps to Reproduce:
1. create a hostgroup that contains a content source, lifecycle environment and content view
2. perform a 'hammer hostgroup info --id [id]'
3.

Actual results:

hammer> hostgroup info --id 1
Id: 1
Name: group1
Title: group1
Puppet CA Proxy Id: 1
Puppet Master Proxy Id: 1
Puppetclasses:

Parameters:

Organizations:
Default Organization
Parent Id:

Expected results:

The output should include details on the content source, lifecycle environment and content view associated with the host group.

Additional info:

Associated revisions

Revision 7ebdebd6 (diff)
Added by Amit Upadhye over 2 years ago

Fixes #18523 - Diplay Content Source in hostgroup info (#479)

History

#1 Updated by Amit Upadhye over 2 years ago

  • Assignee set to Amit Upadhye

#2 Updated by Amit Upadhye over 2 years ago

  • Pull request https://github.com/Katello/hammer-cli-katello/pull/479 added

#3 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) set to 211

#4 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing

#5 Updated by Amit Upadhye over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF