Project

General

Profile

Bug #18556

Katello 3.3 installation fails at 'Exec[foreman-rake-db:seed]'

Added by Karl Sundström about 4 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I'm trying to install Katello 3.3 (katello-3.3.0-2.rc2.el7.noarch) on a clean machine running CentOS Linux release 7.3.1611 (Core).
After a while the installer fails with

"Could not find resource 'Exec[foreman-rake-db:seed]' for relationship from 'Exec[cpinit]' on node katello001.fqdn".

Main Config Menu
1. [✓] Configure certs
2. [✓] Configure foreman
3. [✓] Configure foreman_plugin_ansible
4. [✗] Configure foreman_plugin_bootdisk
5. [✗] Configure foreman_plugin_chef
6. [✗] Configure foreman_plugin_default_hostgroup
7. [✗] Configure foreman_plugin_discovery
8. [✗] Configure foreman_plugin_hooks
9. [✗] Configure foreman_plugin_openscap
10. [✗] Configure foreman_plugin_puppetdb
11. [✓] Configure foreman_plugin_remote_execution
12. [✗] Configure foreman_plugin_setup
13. [✓] Configure foreman_plugin_tasks
14. [✗] Configure foreman_plugin_templates
15. [✓] Configure foreman_proxy
16. [✓] Configure foreman_proxy_content
17. [✓] Configure foreman_proxy_plugin_ansible
18. [✗] Configure foreman_proxy_plugin_dhcp_infoblox
19. [✗] Configure foreman_proxy_plugin_discovery
20. [✗] Configure foreman_proxy_plugin_dns_infoblox
21. [✗] Configure foreman_proxy_plugin_openscap
22. [✓] Configure foreman_proxy_plugin_pulp
23. [✓] Configure foreman_proxy_plugin_remote_execution_ssh
24. [✓] Configure katello
25. Display current config
26. Save and run
27. Cancel run without Saving
Choose an option from the menu... 26
Could not find resource 'Exec[foreman-rake-db:seed]' for relationship from 'Exec[cpinit]' on node katello001.fqdn
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:69:in `mk_relationship'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:35:in `block (2 levels) in evaluate'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:34:in `each'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:34:in `block in evaluate'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:33:in `each'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:33:in `evaluate'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:244:in `block in evaluate_relationships'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:244:in `each'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:244:in `evaluate_relationships'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:465:in `finish'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:143:in `block (2 levels) in compile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:143:in `block in compile'
/usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
/usr/share/ruby/vendor_ruby/puppet.rb:246:in `override'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:121:in `compile'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:34:in `compile'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:95:in `block (2 levels) in compile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:93:in `block in compile'
/usr/share/ruby/vendor_ruby/puppet/util.rb:161:in `block in benchmark'
/usr/share/ruby/benchmark.rb:296:in `realtime'
/usr/share/ruby/vendor_ruby/puppet/util.rb:160:in `benchmark'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:92:in `compile'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:52:in `find'
/usr/share/ruby/vendor_ruby/puppet/indirector/indirection.rb:201:in `find'
/usr/share/ruby/vendor_ruby/puppet/application/apply.rb:222:in `block in main'
/usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
/usr/share/ruby/vendor_ruby/puppet.rb:246:in `override'
/usr/share/ruby/vendor_ruby/puppet/application/apply.rb:198:in `main'
/usr/share/ruby/vendor_ruby/puppet/application/apply.rb:159:in `run_command'
/usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `block (2 levels) in run'
/usr/share/ruby/vendor_ruby/puppet/application.rb:507:in `plugin_hook'
/usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `block in run'
/usr/share/ruby/vendor_ruby/puppet/util.rb:496:in `exit_on_fail'
/usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `run'
/usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:146:in `run'
/usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:92:in `execute'
/usr/bin/puppet:8:in `<main>'
Could not find resource 'Exec[foreman-rake-db:seed]' for relationship from 'Exec[cpinit]' on node katello001.fqdn
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:69:in `mk_relationship'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:35:in `block (2 levels) in evaluate'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:34:in `each'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:34:in `block in evaluate'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:33:in `each'
/usr/share/ruby/vendor_ruby/puppet/parser/relationship.rb:33:in `evaluate'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:244:in `block in evaluate_relationships'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:244:in `each'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:244:in `evaluate_relationships'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:465:in `finish'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:143:in `block (2 levels) in compile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:143:in `block in compile'
/usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
/usr/share/ruby/vendor_ruby/puppet.rb:246:in `override'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:121:in `compile'
/usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:34:in `compile'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:95:in `block (2 levels) in compile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
/usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:93:in `block in compile'
/usr/share/ruby/vendor_ruby/puppet/util.rb:161:in `block in benchmark'
/usr/share/ruby/benchmark.rb:296:in `realtime'
/usr/share/ruby/vendor_ruby/puppet/util.rb:160:in `benchmark'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:92:in `compile'
/usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:52:in `find'
/usr/share/ruby/vendor_ruby/puppet/indirector/indirection.rb:201:in `find'
/usr/share/ruby/vendor_ruby/puppet/application/apply.rb:222:in `block in main'
/usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
/usr/share/ruby/vendor_ruby/puppet.rb:246:in `override'
/usr/share/ruby/vendor_ruby/puppet/application/apply.rb:198:in `main'
/usr/share/ruby/vendor_ruby/puppet/application/apply.rb:159:in `run_command'
/usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `block (2 levels) in run'
/usr/share/ruby/vendor_ruby/puppet/application.rb:507:in `plugin_hook'
/usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `block in run'
/usr/share/ruby/vendor_ruby/puppet/util.rb:496:in `exit_on_fail'
/usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `run'
/usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:146:in `run'
/usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:92:in `execute'
/usr/bin/puppet:8:in `<main>'
Preparing installation Done
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/foreman-installer/katello.log

History

#1 Updated by Karl Sundström about 4 years ago

  • Priority changed from High to Low

I had this vm snapshotted so I removed the snapshot and ran the installer with the same settings again.
This time it worked. No clue what the difference could possibly be, some sort of timing issue?

#2 Updated by Justin Sherrill about 4 years ago

  • Status changed from New to Rejected

We'll go ahead and close this since we haven't been able to reproduce and I guess you aren't able to either. If you can reproduce this or someone else hits this, please reopen!
Thanks

Also available in: Atom PDF