Project

General

Profile

Bug #18569

Remote execution jobs in state queued, unable to proceed or cancel

Added by Ivan Necas over 5 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Description of problem:

i have remote execution jobs in the queued state. As a user i am unable to cleanup this state.
The queued state happened because there was an error resolving the hosts during the execution phase, see https://bugzilla.redhat.com/show_bug.cgi?id=1397185.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Login as a user that does not have explicit association with org or loc, see BZ1397185
3. Execute a job

Actual results:
Job in queued state. Unable to proceed,. cancel, delete

Expected results:
Jobs can be retried and/or canceled.

Additional info:


Related issues

Is duplicate of Foreman Remote Execution - Bug #19937: it is hard (or there is no way at all) to cancel pending tasks from old remote execution jobClosed2017-06-06

History

#1 Updated by Ivan Necas over 5 years ago

  • Subject changed from Remote execution jobs in state queued, unable to proceed or cancel to Remote execution jobs in state queued, unable to proceed or cancel
  • Target version set to 1.12.0

#2 Updated by Ivan Necas almost 5 years ago

  • Status changed from New to Duplicate

#3 Updated by Ivan Necas almost 5 years ago

  • Is duplicate of Bug #19937: it is hard (or there is no way at all) to cancel pending tasks from old remote execution job added

Also available in: Atom PDF