Project

General

Profile

Bug #18703

Unable to delete the composite content view version after upgrade

Added by Brad Buckingham over 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Description of problem:

When deleting the version of a content view the task gives an error and keeps hanging.
Now they have an 'emtpy' content view version which can't deleted

Here is the error message while deleting the content view version:

The error messages says : "[Errno 2] No such file or directory: '/var/lib/pulp/published/yum/https/repos/Default_Organization/content_views/CV_ALL/6.0/custom/EPEL/listing'"

On file system, we see that there is no directory for the version "6.0"

  1. ls l /var/lib/pulp/published/yum/https/repos/Default_Organization/content_views/CV_ALL
    total 4
    drwxr-xr-x. 4 apache apache 47 Aug 4 10:21 8.0
    drwxr-x--
    . 4 apache apache 47 Aug 12 13:50 8.1
    rw-r--r-. 1 apache apache 11 Aug 12 13:50 listing

How reproducible:
only on user environment

Additional Info:

  • We tried creating the directory path manually with proper permissions but still that could not help.
  1. mkdir -p /var/lib/pulp/published/yum/https/repos/Default_Organization/content_views/CV_ALL/6.0/custom/EPEL
  2. touch /var/lib/pulp/published/yum/https/repos/Default_Organization/content_views/CV_ALL/6.0/custom/EPEL/listing
  3. chown apache:apache -R /var/lib/pulp/published/yum/https/repos/Default_Organization/content_views/CV_ALL/6.0
  • The user tried to delete the CCV but still, server does not allow to delete and fail with the same error:

    description: 'Pulp exception occurred: PulpExecutionException'
    sub_errors:
    - code: PLP0000
    data: {}
    description: "[Errno 2] No such file or directory: '/var/lib/pulp/published/yum/https/repos/Default_Organization/content_views/CV_ALL/6.0/custom/EPEL/listing'"
    sub_errors: []


Related issues

Is duplicate of Katello - Bug #15567: Katello 3.0 - Failed to delete a content viewResolved2016-07-03

History

#1 Updated by Brad Buckingham over 2 years ago

  • Subject changed from Unable to delete the composite content view version after upgrade to Unable to delete the composite content view version after upgrade
  • Target version set to 169

Need to investigate cause of issue. This could be something unique to the user's environment. Refer to bugzilla for more details.

#2 Updated by Brad Buckingham over 2 years ago

  • Legacy Backlogs Release (now unused) set to 114

#3 Updated by Brad Buckingham over 2 years ago

  • Is duplicate of Bug #15567: Katello 3.0 - Failed to delete a content view added

#4 Updated by Brad Buckingham over 2 years ago

  • Status changed from New to Duplicate

This appears to be the same issue as http://projects.theforeman.org/issues/15567.

Also available in: Atom PDF