Project

General

Profile

Bug #18819

Publish content view with puppet module fails "Validation failed: Puppet environment can't be blank"

Added by Justin Sherrill about 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Content Views
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

1. create a content view
2. Add a puppet module
3. attempt to publish the view

Validation failed: Puppet environment can't be blank

---
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/validations.rb:79:in
`raise_record_invalid'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/validations.rb:43:in
`save!'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/attribute_methods/dirty.rb:29:in
`save!'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/transactions.rb:291:in
`block in save!'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/transactions.rb:351:in
`block in with_transaction_returning_status'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:213:in
`block in transaction'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/connection_adapters/abstract/transaction.rb:184:in
`within_new_transaction'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:213:in
`transaction'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/transactions.rb:220:in
`transaction'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/transactions.rb:348:in
`with_transaction_returning_status'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/activerecord-4.2.8/lib/active_record/transactions.rb:291:in
`save!'"
- "/home/vagrant/git/katello/app/lib/katello/lazy_accessor.rb:87:in `save!'"
- "/home/vagrant/git/katello/app/models/katello/content_view_puppet_environment.rb:102:in
`index_content'"
- "/home/vagrant/git/katello/app/lib/actions/pulp/content_view_puppet_environment/index_content.rb:12:in
`run'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/dynflow-0.8.20/lib/dynflow/action.rb:506:in
`block (3 levels) in execute_run'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/dynflow-0.8.20/lib/dynflow/middleware/stack.rb:26:in
`call'"
- "/home/vagrant/.rvm/gems/ruby-2.2.4/gems/dynflow-0.8.20/lib/dynflow/middleware/stack.rb:26:in
`pass'"

Associated revisions

Revision b941f26a (diff)
Added by Justin Sherrill about 2 years ago

Fixes #18819 - set user during puppet env indexing

issue caused by http://projects.theforeman.org/issues/16982

History

#1 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6654 added

#2 Updated by Justin Sherrill about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill about 2 years ago

  • Legacy Backlogs Release (now unused) set to 211

Also available in: Atom PDF