Project

General

Profile

Bug #19113

Rebuilding the virtual machine on RHEV from Satellite with the reboot flag enabled does not reboot the vm.

Added by Ivan Necas over 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - oVirt
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When try to re-provision an already provisioned by Satellite 6 virtual machine residing on RHEV by going to Foreman Web GUI ---> All hosts ---> Select a Virtual Machine on RHEV ---> Build ---> Check "Reboot now" ---> Build. The client host does not reboot on the RHEV instead it is stopped.

Red Hat Enterprise Virtualization Manager Version: 3.6.7

1. Create a compute resource for RHEV and provision a system on RHEV using the Foreman

2. Once it is built rebuild it.
Foreman Web GUI ---> All hosts ---> Select a Virtual Machine on RHEV ---> Build ---> Check "Reboot now" ---> Build

3. The system does not reboot , we have to manually power it on from the Foreman web ui.

Actual results:
Client system does not reboot

Expected results:
Client system should reboot.

Additional info:
It looks like that the Foreman through fog immediately tries to Power on the Virtual Machine on the RHEV while it still being shutdown. We notice below message in the RHEV engine logs.


Related issues

Related to Foreman - Bug #15441: [oVirt] "VM is running" error when deleting hostClosed2016-06-16

Associated revisions

Revision 07ff65c0 (diff)
Added by Ivan Necas about 1 year ago

Fixes #19113 - use fog-ovirt method for rebooting

While fixing the waiting for stopped vm in reboot there.

History

#1 Updated by Ivan Necas over 1 year ago

  • Subject changed from Rebuilding the virtual machine on RHEV from Satellite with the reboot flag enabled does not reboot the vm. to Rebuilding the virtual machine on RHEV from Satellite with the reboot flag enabled does not reboot the vm.
  • Category changed from Unattended installations to Compute resources - oVirt

#2 Updated by Ivan Necas over 1 year ago

  • Assignee set to Ivan Necas
  • Pull request https://github.com/fog/fog/pull/3954 added

The patch sent to ovirt

#3 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4672 added

#4 Updated by Ivan Necas about 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Daniel Lobato Garcia about 1 year ago

  • Legacy Backlogs Release (now unused) set to 240

#6 Updated by Ivan Necas about 1 year ago

  • Related to Bug #15441: [oVirt] "VM is running" error when deleting host added

Also available in: Atom PDF