Project

General

Profile

Bug #1949

VMware creation: vm's always get 768MB memory

Added by Siert Z. over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
VM management
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Even if specified else, all my VMs end up with 768MB memory. Using ESX 5 with the vmware branch of november 15th 2012.

The post to foreman seems fine:

Started POST "/compute_resources/1-myesx/vms" for 192.168.56.1 at Thu Nov 15 11:04:17 +0100 2012
  Processing by ComputeResourcesVmsController#create as HTML
  Parameters: {"vm"=>{"name"=>"foreman_1352973844", "path"=>"Datacenters/DC1/vm", "volumes_attributes"=>{"new_volumes"=>{"name"=>"Hard disk", "_delete"=>"", "datastore"=>"ESX2 SAS", "size_gb"=>"10"}, "0"=>{"name"=>"Hard disk", "_delete"=>"", "datastore"=>"ESX2 SAS", "size_gb"=>"10"}}, "cpus"=>"1", "memory"=>"4294967296", "interfaces_attributes"=>{"0"=>{"_delete"=>"", "network"=>"Intern"}, "new_interfaces"=>{"_delete"=>"", "network"=>"Intern"}}, "start"=>"1", "cluster"=>"AICD"}, "commit"=>"Save changes", "compute_resource_id"=>"1-myesx", "utf8"=>"✓", "authenticity_token"=>"token"}
Redirected to http://192.168.56.104:3000/compute_resources/1-myesx/vms
Completed 302 Found in 2887ms

screenshot_memory.png View screenshot_memory.png 44.1 KB Siert Z., 11/15/2012 08:02 AM
Screenshot memory

Associated revisions

Revision cfa6a3f5 (diff)
Added by Ohad Levy over 9 years ago

fixes #1949 - VMware creation: vm's always get 768MB memory

I've removed the select box too, and would add a slider in a later commit

History

#1 Updated by Sam Kottler over 9 years ago

  • Assignee set to Ohad Levy

Assigning this to Ohad since he's done most of the VMWare work.

#2 Updated by Siert Z. over 9 years ago

Note that foreman host virtual machine properties will always list 512MB (536870912) installed.

#3 Updated by Sam Kottler over 9 years ago

  • Category set to VM management
  • Status changed from New to Assigned
  • Assignee changed from Ohad Levy to Sam Kottler

I'm going to dig into this now.

#4 Updated by Sam Kottler over 9 years ago

I can reproduce this issue. I spent some time looking at it today and think I know the root cause so hopefully I'll get a PR in tomorrow!

#5 Updated by Ohad Levy over 9 years ago

  • Status changed from Assigned to Ready For Testing
  • Assignee changed from Sam Kottler to Ohad Levy
  • % Done changed from 0 to 100

#6 Updated by Ohad Levy over 9 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF