Project

General

Profile

Bug #20213

foreman down after upgrading to latest version

Added by cristian falcas over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hello,

After upgrading to 1.15.1, we have this error:

c2017-07-05 07:41:23 [app] [W] Failed running foreman-tasks daemon
 | NameError: uninitialized constant ForemanOpenscap::ApplicationRecord
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.7.3/app/models/foreman_openscap/asset.rb:2:in `<module:ForemanOpenscap>'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.7.3/app/models/foreman_openscap/asset.rb:1:in `<top (required)>'
 | /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:54:in `require'
 | /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:54:in `require'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/polyglot-0.3.4/lib/polyglot.rb:65:in `require'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/engine.rb:472:in `block (2 levels) in eager_load!'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/engine.rb:471:in `each'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/engine.rb:471:in `block in eager_load!'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/engine.rb:469:in `each'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/engine.rb:469:in `eager_load!'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/engine.rb:346:in `eager_load!'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/application/finisher.rb:56:in `each'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/application/finisher.rb:56:in `block in <module:Finisher>'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:30:in `instance_exec'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:30:in `run'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:55:in `block in run_initializers'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:226:in `block in tsort_each'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:348:in `block (2 levels) in each_strongly_connected_component'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:420:in `block (2 levels) in each_strongly_connected_component_from'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:420:in `block (2 levels) in each_strongly_connected_component_from'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:429:in `each_strongly_connected_component_from'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:419:in `block in each_strongly_connected_component_from'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:44:in `each'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:44:in `tsort_each_child'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:413:in `call'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:413:in `each_strongly_connected_component_from'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:419:in `block in each_strongly_connected_component_from'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:44:in `each'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:44:in `tsort_each_child'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:413:in `call'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:413:in `each_strongly_connected_component_from'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:347:in `block in each_strongly_connected_component'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:345:in `each'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:345:in `call'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:345:in `each_strongly_connected_component'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:224:in `tsort_each'
 | /opt/rh/rh-ruby22/root/usr/share/ruby/tsort.rb:203:in `tsort_each'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/initializable.rb:54:in `run_initializers'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/application.rb:352:in `initialize!'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/railtie.rb:194:in `public_send'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/railties-4.2.5.1/lib/rails/railtie.rb:194:in `method_missing'
 | /usr/share/foreman/config/environment.rb:5:in `<top (required)>'
 | /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:54:in `require'
 | /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:54:in `require'
 | /opt/rh/sclo-ror42/root/usr/share/gems/gems/polyglot-0.3.4/lib/polyglot.rb:65:in `require'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.9.3/lib/foreman_tasks/dynflow/daemon.rb:43:in `run'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.9.3/lib/foreman_tasks/dynflow/daemon.rb:73:in `block (2 levels) in run_background'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/application.rb:265:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/application.rb:265:in `block in start_proc'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/daemonize.rb:84:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/daemonize.rb:84:in `call_as_daemon'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/application.rb:269:in `start_proc'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/application.rb:295:in `start'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:49:in `block (3 levels) in watch'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:49:in `fork'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:49:in `block (2 levels) in watch'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:43:in `each'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:43:in `block in watch'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:42:in `loop'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:42:in `watch'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:66:in `block in start_with_pidfile'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:61:in `fork'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:61:in `start_with_pidfile'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/monitor.rb:92:in `start'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/application_group.rb:141:in `create_monitor'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/application.rb:283:in `start'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/controller.rb:56:in `run'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons.rb:193:in `block in run_proc'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/cmdline.rb:88:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons/cmdline.rb:88:in `catch_exceptions'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/daemons-1.2.3/lib/daemons.rb:192:in `run_proc'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.9.3/lib/foreman_tasks/dynflow/daemon.rb:67:in `block in run_background'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.9.3/lib/foreman_tasks/dynflow/daemon.rb:66:in `times'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.9.3/lib/foreman_tasks/dynflow/daemon.rb:66:in `run_background'
 | /usr/bin/foreman-tasks:5:in `<main>'

Packages installed:

# rpm -qa | grep "foreman\|katello" | sort
foreman-1.15.1-1.el7.noarch
foreman-cli-1.15.1-1.el7.noarch
foreman-compute-1.15.1-1.el7.noarch
foreman-debug-1.15.1-1.el7.noarch
foreman-ec2-1.15.1-1.el7.noarch
foreman-postgresql-1.15.1-1.el7.noarch
foreman-proxy-1.15.1-1.el7.noarch
foreman-selinux-1.15.1-1.el7.noarch
katello-agent-3.0.0-2.el7.noarch
katello-agent-fact-plugin-3.0.0-2.el7.noarch
katello-certs-tools-2.4.0-1.el7.noarch
katello-selinux-3.0.2-1.el7.noarch
rubygem-foreman_scap_client-0.3.0-1.el7.noarch
tfm-rubygem-foreman_abrt-0.0.7-1.fm1_12.el7.noarch
tfm-rubygem-foreman_docker-3.2.1-1.fm1_15.el7.noarch
tfm-rubygem-foreman_openscap-0.7.3-1.fm1_15.el7.noarch
tfm-rubygem-foreman-tasks-0.9.3-1.fm1_15.el7.noarch
tfm-rubygem-foreman-tasks-core-0.1.3-1.fm1_15.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.10.2-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-5.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.4-2.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.10-2.fm1_12.el7.noarch
tfm-rubygem-hammer_cli_katello-0.10.0-1.el7.noarch
tfm-rubygem-katello-3.4.2-1.el7.noarch
tfm-rubygem-puppetdb_foreman-3.0.2-1.fm1_15.el7.noarch


Related issues

Is duplicate of OpenSCAP - Bug #20124: Foreman 1.15.1 fails to start when running tfm-rubygem-foreman_openscap 0.7.3Closed2017-06-27

History

#1 Updated by cristian falcas over 4 years ago

Downgrading to tfm-rubygem-foreman_openscap-0.7.2-1.fm1_15.el7.noarch seems to fix this issue

#2 Updated by Anonymous over 4 years ago

please update to foreman_openscap 0.7.4, which can be found in the repos since now.

#3 Updated by Anonymous over 4 years ago

  • Is duplicate of Bug #20124: Foreman 1.15.1 fails to start when running tfm-rubygem-foreman_openscap 0.7.3 added

#4 Updated by Anonymous over 4 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF