Project

General

Profile

Bug #21274

Content view version's Errata tab is absent if version contains only RH repos

Added by Brad Buckingham over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1492114

Description of problem:
For 6.3 packages and errata tabs of content view version are shown only in case corresponding content is present inside the version. However, seems like errata check only counts custom repos errata and ignores RH repos, so in case you have content view version with RH repos (with errata inside) only, you won't be able to navigate to Errata tab.
Worth mentioning that it's only tab displaying issue - if you try to navigate to errata list by specifying corresponding URL in browser, errata table will be shown with no issues.

How reproducible:
Always

Steps to Reproduce:
1. Enable some RH repo, for example Satellite tools, and synchronize it
2. Create new content view, add mentioned RH repo in it
3. Publish a new version of content view.
4. Attempt to open version's errata list, goto Content -> Content views -> #content_view# -> Versions -> Version 1.0 -> Errata

Actual results:
Errata tab is not present, it's not possible to manage content view version's errata.

Expected results:
Errata tab is present

Associated revisions

Revision fafe91dc (diff)
Added by Brad Buckingham over 4 years ago

fixes #21274 - determine cvv errata based on errata_counts total

This is a small change to address an edge case where when a user
would view the details of a content view version in the UI, they
may not see the Errata tab.

This was occuring in cases where the errata_counts had null
as the first entry in the result set (e.g.
errata_counts['security']==null). Since the
version['errata_counts'] (if included) will include a
'total', this logic will use that total to decide if the
Errata tab will be shown.

History

#1 Updated by Brad Buckingham over 4 years ago

  • Subject changed from Content view version's Errata tab is absent if version contains only RH repos to Content view version's Errata tab is absent if version contains only RH repos
  • Target version set to 225

#2 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 250

#3 Updated by Brad Buckingham over 4 years ago

  • Assignee set to Brad Buckingham
  • Status changed from New to Assigned

#4 Updated by The Foreman Bot over 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7022 added

#5 Updated by Brad Buckingham over 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF