Project

General

Profile

Bug #2224

Selecting a RHEV 3.1 template does not work properly

Added by Jason Montleon over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Selecting a template on a RHEV 3.1 cluster causes the an error like below and as a result it appears interfaces and volumes do not populate properly.

Started POST "/compute_resources/1-phx1-soc-rhev/hardware_profile_selected" for 10.16.197.109 at Tue Feb 19 15:05:43 -0500 2013
Processing by ComputeResourcesController#hardware_profile_selected as
Parameters: {"hwp_id"=>"d9e12cb0-b0eb-4967-910d-f4317ba3ef88", "id"=>"1-phx1-soc-rhev"}
Operation FAILED: undefined method `[]' for nil:NilClass
Rendered common/500.rhtml (6.4ms)
Completed 500 Internal Server Error in 444ms (Views: 9.1ms | ActiveRecord: 0.0ms)

production.log production.log 61.9 KB Jason Montleon, 02/21/2013 09:34 PM

Associated revisions

Revision c2096fe0 (diff)
Added by Amos Benari about 6 years ago

fixes #2224 Selecting a RHEV 3.1 template does not work properly

History

#1 Updated by Ohad Levy over 6 years ago

  • Category set to Compute resources
  • Assignee set to Amos Benari
  • Target version set to 1.2.0

#2 Updated by Amos Benari over 6 years ago

  • Status changed from New to Need more information

Could not reproduce. Can you please add the error from foreman log?
If the issue can be reproduced, please also add steps to reproduce.
Thanks.

#3 Updated by Jason Montleon about 6 years ago

The output I listed is what I am seeing in the logs. I sent the full production.log over for your review.

I set up a new server and pointed it at an Ovirt 3.2/Fedora 18 setup I have and I see the same thing.

#4 Updated by Ohad Levy about 6 years ago

can you please enable debug and send the full production log?

#5 Updated by Ohad Levy about 6 years ago

btw: i did not see the log in the ticket

#6 Updated by Jason Montleon about 6 years ago

Attached production.log with debug enabled.

By the way, Foreman is runnning on RHEL 6, in case it makes a difference. I can probably provision a server running on Fedora tomorrow just to make sure it's not something distro specific.

#7 Updated by Jason Montleon about 6 years ago

Doing this makes it work, the template info populates, and I can provision, but I have no idea what removing it breaks.


--- /usr/lib/ruby/gems/1.8/gems/rbovirt-0.0.15/lib/ovirt/volume.rb.orig    2013-02-22 09:28:45.000000000 -0500
+++ /usr/lib/ruby/gems/1.8/gems/rbovirt-0.0.15/lib/ovirt/volume.rb    2013-02-22 09:28:56.000000000 -0500
@@ -35,7 +35,7 @@
      @format = (xml/'format').first.text
      @sparse = (xml/'sparse').first.text
      @status = (xml/'status').first.text
-     @vm = Link::new(@client, (xml/'vm').first[:id], (xml/'vm').first[:href])
+     # @vm = Link::new(@client, (xml/'vm').first[:id], (xml/'vm').first[:href])
     end

#8 Updated by Jason Montleon about 6 years ago

I found the 'what it breaks'; the vm name does not get set properly in rhev. ends up being something like foreman_XXXXXXX where the X's are numbers.

#9 Updated by Amos Benari about 6 years ago

  • Status changed from Need more information to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF