Project

General

Profile

Bug #24134

Red Hat Enterprise Linux Atomic Host (Kickstart) fails to enable

Added by John Mitsch about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

This returns an error %{unused_substitutes} cannot be specified for %{content_name} as that information is not substitutable in %{content_url}

To reproduce: import manifest and try to enable said repo

Associated revisions

Revision 31ab44e2 (diff)
Added by John Mitsch about 3 years ago

Fixes #24134 - Error enabling atomic kickstart repo

This commit addresses a few things:
- "basearch" was being passed when enabling RHEL atomic kickstart repo,
where there is no $basearch needed for the CDN. This is because we
are using the value "Unspecified" to fill in the UI when there is
no arch. This was making its way into the API call, where basearch
shouldn't be defined.
- The error message being returned wasn't properly templated. This was
fixed and tests are added.
- "Kickstarter" is an crowdsourcing site and shouldn't be an option
in the content type drop down :stuck_out_tongue_closed_eyes:

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7491 added

#2 Updated by John Mitsch about 3 years ago

  • Bugzilla link set to 1580438

#3 Updated by John Mitsch about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#4 Updated by Brad Buckingham about 3 years ago

  • Triaged set to No
  • Target version set to Katello 3.7.0

Also available in: Atom PDF