Project

General

Profile

Actions

Bug #24391

closed

CA cert can't be specified in API while adding a RHEV Compute Resource

Added by Ido Kanner almost 6 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Description of problem:
In WebUI, it is possible (sometimes necessary) to specify a CA certificate for https communication with RHEV. This is done using the "X509 Certification Authorities" field in the new Compute Resource creation form.

In API, this is not possible. Consequently, it is also not possible in Hammer, Nailgun and other tools using API.

Steps to Reproduce:
http://SAT_HOSTNAME/apidoc/v2/compute_resources/create.html

Actual results:
No parameter for CA cert

Expected results:
public_key (id of the WebUI input field) parameter


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Bug #25491: CA cert can't be specified in API while adding a RHEV Compute ResourceClosedShira MaximovActions
Actions #1

Updated by The Foreman Bot almost 6 years ago

  • Pull request https://github.com/theforeman/foreman/pull/5877 added
Actions #2

Updated by The Foreman Bot almost 6 years ago

  • Status changed from Assigned to Ready For Testing
Actions #3

Updated by Anonymous about 5 years ago

  • Is duplicate of Bug #25491: CA cert can't be specified in API while adding a RHEV Compute Resource added
Actions #4

Updated by Anonymous about 5 years ago

  • Status changed from Ready For Testing to Duplicate
Actions

Also available in: Atom PDF