Project

General

Profile

Bug #2479

Failed to generate external nodes for <> with undefined method `value_for' for #<LookupKey>

Added by Ohad Levy about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Smart Variables
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Related issues

Is duplicate of Foreman - Bug #2478: smart-variable match by hostgroup label created by 1.1 stopped working Closed2013-05-09

History

#1 Updated by Ohad Levy about 6 years ago

it seems like it used in at least two places:

app/models/host/managed.rb:      p[k.to_s] = k.value_for(self)
app/controllers/lookup_keys_controller.rb:      value = { :value => @lookup_key.value_for(host) }

#2 Updated by Ohad Levy about 6 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF