Project

General

Profile

Bug #25195

katello-remove does not completely remove data on mounted filesystems

Added by Chris Roberts about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Tooling
Target version:

Description

Description of problem:

katello-remove does not completely remove the data on mounted directory structures

Version-Release number of selected component (if applicable):

Satellite 6.3.1
RHEL 7.5

How reproducible:

Always

Steps to Reproduce:

1. Install a new RHEL host with mounted filesystems following guidelines [1]:

/var/lib/pgsql
/var/lib/mongodb

2. Install Satellite server bits

  1. yum install satellite
  2. satellite-installer

3. Remove [2] Satellite 6.3 server bits:

  1. katello-remove

4. Change hostname to something else

  1. hostnamectl set-hostname satname2

5. Install Satellite server bits again

  1. yum install satellite
  2. satellite-installer

Actual results:

Since the data does not remove completely, remnants of the old install still stick around, for example, in this scenario, the hostname was changed during the second installation and the capsule id is now "2" instead of "1" for a fresh installation.

/var/lib/pgsql was not cleaned up properly so the new installation took the data from this directory and used it for Satellite 6

Expected results:

katello-remove should remove all the data in these directories

Maybe add some logic to check if the filesystem is mounted, and ask the user if it's OK to remove the data in that path.

We see that /var/lib/pgsql is a mounted filesystem, is it OK to remove /var/lib/pgsql/* ?

History

#1 Updated by The Foreman Bot about 2 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/3092 added

#2 Updated by Chris Roberts about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.0
  • Category changed from RPMs to Tooling
  • Project changed from Packaging to Katello
  • Found in Releases Katello 3.9.0 added
  • Fixed in Releases Katello 3.10.0 added

#3 Updated by Chris Roberts about 2 years ago

  • Status changed from Ready For Testing to Resolved

#4 Updated by The Foreman Bot almost 2 years ago

  • Pull request https://github.com/theforeman/foreman-packaging/pull/3155 added

Also available in: Atom PDF