Project

General

Profile

Bug #25541

Singleton actions may not start after unclean shutdown

Added by Adam Ruzicka about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1652060

Description of problem:
We trigger singleton actions (LOCE, EQM) from dynflow's on_init hook. Recently we moved invalidation to happen after running the hooks. It is now possible to get into a situation where

1) On init hook is run, singleton actions fail because a lock is being held by another execution plan
2) Invalidation is performed, old actions fail with abnormal termination error and their locks are released
3) The satellite is left without LOCE and EQM

We used to do steps 1 and 2 in reverse order which worked, but changed that because of another issue.

How reproducible:
always

Steps to Reproduce:
0. (optional) Patch LOCE to make this easier to reproduce, add a lengthy sleep into its run method
1. systemctl kill --signal=9 foreman-tasks when the singleton action's step is running
2. systemctl restart foreman-tasks

Actual results:
New singleton actions fail with "$ACTION_CLASS is already active", old singleton actions fail with abnormal termination error, satellite is left without LOCE and EQM.

Expected results:
Old singleton actions get cleaned up, new are started.

Additional info:

Associated revisions

Revision c23ae22b (diff)
Added by Adam Ruzicka about 4 years ago

Fixes #25541 - Trigger singleton actions in post init hook

History

#1 Updated by The Foreman Bot about 4 years ago

  • Assignee set to Adam Ruzicka
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7848 added

#2 Updated by Adam Ruzicka about 4 years ago

  • Subject changed from Singleton actions may not start after unclean shutdown to Singleton actions may not start after unclean shutdown
  • Pull request https://github.com/Dynflow/dynflow/pull/307 added

#3 Updated by Christine Fouant about 4 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.1

#4 Updated by Anonymous about 4 years ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Adam Ruzicka about 4 years ago

  • Fixed in Releases Katello 3.11.0 added

#6 Updated by Eric Helms about 4 years ago

  • Target version deleted (Katello 3.9.1)

Also available in: Atom PDF