Project

General

Profile

Bug #2568

Foreman Installer node.rb script not working with 1.2

Added by Jason Montleon almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Puppet integration
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

in the node.rb, installed by the foreman installer, in def enc(certname)
I had to change the line:
req = Net::HTTP::Get.new(foreman_url)
to:
req = Net::HTTP::Get.new(uri.path + "?" + uri.query)

I'm a little perplexed because the first works with 1.1, but seems to no longer work in 1.2, which makes little sense to me. Not sure if anyone else can reproduce.

Associated revisions

Revision b7ba7c3c (diff)
Added by Dominic Cleal almost 6 years ago

fixes #2568 - don't pass entire URL to Get, use request_uri consistently

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Category set to Puppet integration
  • Target version set to 1.2.0

#2 Updated by Dominic Cleal almost 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Dominic Cleal

I can't reproduce this and can't think why it would change (my RHEL 6.4 installer host is fine), but the docs agree with your fix, so let's do it.

https://github.com/theforeman/puppet-foreman/pull/71

#3 Updated by Dominic Cleal almost 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF