Project

General

Profile

Bug #25761

uploading a package to custom repo does not trigger sync of Capsule in Library LE

Added by Pavel Moravec over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
Having a Capsule in Library Lifecycle Environment, it should get synchronized all content from Satellite.

But when I upload a package to a custom repo in a custom product, the change is published on Satellite noly and nothing is propagated to the Capsule.

(same applies after uploading a package to RH repo, but I dont assume a customer will manually change content of RH repo)

Version-Release number of selected component (if applicable):
Sat 6.2.12

How reproducible:
100%

Steps to Reproduce:
1. Have a Capsule, fully synced.
2. Create a product, a repo and upload a package there:

hammer -u admin -p redhat product create --name myproduct --organization-id=1

hammer -u admin -p redhat repository create --name myrepo --product=myproduct --organization-id=1 --content-type=yum

hammer -u admin -p redhat repository upload-content --name=myrepo --organization-id=1 --product=myproduct --path /path/to/some/repo.rpm

3. Ensure all tasks completed (more precisely: no capsule sync task is in progress).
4. Check if the repository has that package - run both on Sat and Caps:
ls /var/lib/pulp/published/yum/master/yum_distributor/*-myproduct-myrepo/*/

(in above command, 1st '*' is expanded to Organization and 2nd to timestamp since Epoch - both shall be unique)

5. Synchronize the Caps:
hammer -u admin -p redhat capsule content synchronize --id 2 --organization-id 1

6. Check if the repo has that package also on Caps:
ls /var/lib/pulp/published/yum/master/yum_distributor/*-myproduct-myrepo/*/

Actual results:
4. shows a package and metadata exists only on Satellite. Capsule does not have that repo at all.
6. shows the repo properly created&published also to Capsule.

Expected results:
The repo is properly created&synced&published even in step 4.

Associated revisions

Revision cd1b0b50 (diff)
Added by Pavel Moravec over 1 year ago

Fixes #25761: Invoke Capsule sync of a repo after package upload

When an user uploads a package to a repository, the repo should be
synced to Capsules in the repo's Lifecycle Environment.

Signed-off-by: Pavel Moravec <>

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7906 added

#2 Updated by Justin Sherrill over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.11.0

#3 Updated by Pavel Moravec over 1 year ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF