Project

General

Profile

Bug #28916

Machine creation fails on VMware when an interface uses NSX-T based portgroup

Added by Rob See almost 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hi,

While trying to build a new machine on vcenter, using a nvds (NSX-T 2.5) port group, it fails with "Could not find virtual machine network interface matching ... "

Turning on debugging, this is what the nic data structure looks like:
2020-02-03T22:37:34 [D|app|c3455bb4] Orchestration::Compute: Trying to match network interfaces from fog <Fog::Vsphere::Compute::Interfaces
server_id="50012b3f-4037-f359-4a90-3b98047f61f5"
[
<Fog::Vsphere::Compute::Interface
mac="00:50:56:81:b8:54",
network=nil,
name="Network adapter 1",
status="untried",
connected=false,
summary="nsx.LogicalSwitch: 048e792e-ed9e-48d9-8568-ba40f2eb0d7d",
type=RbVmomi::VIM::VirtualE1000,
key=4000,
virtualswitch=nil,
server_id="50012b3f-4037-f359-4a90-3b98047f61f5"
>
]
>

I assume the issue is that the value for network is nil instead of dvportgroup-xxx

History

#1 Updated by Rob See almost 3 years ago

  • Category set to Compute resources - VMware

This looks to be caused by fog-vsphere not setting "network" correctly in def raw_to_hash(nic) file: list_vm_interfaces.rb

#2 Updated by Eric Söderman almost 3 years ago

I think this PR will fix this: https://github.com/fog/fog-vsphere/pull/246

#4 Updated by treyormsbee-interop please_edit_me over 2 years ago

Im having the same issue, looks like that PR was merged. Is there an easy way to integrate that into 1.24.2 that I already installed?

Edit: looks like it is as simple as overwriting the lib directory, at least that lets me keep working for now.

#5 Updated by Tomer Brisker almost 2 years ago

  • Status changed from New to Resolved

Looks like this was resolved in fog-vsphere 3.3 which is available in Foreman 2.0 and newer.

Also available in: Atom PDF