Project

General

Profile

Bug #29661

hammer tab-completion crash

Added by Pablo Escobar over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

I have installed Katello-3.15 and Foreman 2.0. As I only plan to use ansible I didn't installed puppet. These are the specific options I used for the installer:

#!/bin/bash

# create dummy puppet group to workaround this bug
# https://projects.theforeman.org/issues/16241
grep puppet /etc/group &> /dev/null  ||  groupadd --gid 5000 puppet

sudo foreman-installer \
--no-colors \
--tuning medium \
--puppet-server=false \
--puppet-server-ca=false \
--no-enable-puppet \
--enable-foreman-cli-ansible \
--enable-foreman-plugin-ansible \
--enable-foreman-proxy-plugin-ansible \
--foreman-proxy-manage-puppet-group=false \
--foreman-proxy-content-puppet=false \
--foreman-proxy-puppet=false \
--foreman-proxy-puppetca=false \
--foreman-proxy-tftp=false \
--foreman-email-smtp-address="my.smtp.com" \
--foreman-initial-admin-email="admin@email.com" \
--foreman-initial-admin-password="xXXXXxxxXXXX" \
--foreman-initial-organization="my_org" \
--foreman-initial-location="my_location" \
--scenario katello

I have configured some products, content views and activation keys in katello which work fine. I can register katello clients using the subscription-manager and use the yum repos in katello without issues. I have done all the katello configuration using the official ansible collection in ansible galalaxy (https://galaxy.ansible.com/theforeman/foreman)

I can execute commands using hammer cli but when I try to use the tab-completion in hammer I get this error:

environment command is deprecated and will be removed in one of the future versions. Please use puppet-environment command instead.
report command is deprecated and will be removed in one of the future versions. Please use config-report command instead.
Error: uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable
Did you mean?  HammerCLIKatello::LifecycleEnvironmentNameMapping

I have found some similar bug reports that claim that this problem is fixed in latest release (e.g. https://bugzilla.redhat.com/show_bug.cgi?id=1730026) but I also get the same problem when running the commands described in that bug report. e.g

$> hammer docker manifest list
Error: uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable
Did you mean?  HammerCLIKatello::LifecycleEnvironmentNameMapping

History

#1 Updated by Oleh Fedorenko over 1 year ago

  • Triaged changed from No to Yes
  • Status changed from New to Closed

This was due to the old hammer_cli_foreman_docker plugin which is required by hammer-cli-katello. The new version was released, so this is no longer reproducible.

If the issue still persists, please reopen.

Also available in: Atom PDF