Project

General

Profile

Bug #33629

In Katello 4.1 upgrade, installer failed with exit status 6 in the db:migrate stage.

Added by Ian Ballou 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2010230

Description of problem: In the Katello 4.1 upgrade, installer failed with exit status 6 in the db:migrate stage.

Version-Release number of selected component (if applicable):
Katello 4.1

How reproducible:
always

Steps to Reproduce:
Upgrade to Katello 4.1 with a Katello server that has a repository with an arch of something other than 'noarch' and whose content has a url without '$basearch' in it. Meeting those criteria triggers the migration bug.

stage.the/Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: change from 'notrun' to ['0'] failed: '/usr/sbin/foreman-rake db:migrate' returned 1 instead of one of [0]

Actual results:
foreman-rake-db:migrate failed in the installer

Expected results:
foreman-rake-db:migrate should be completed successfully.

Additional info:

Associated revisions

Revision c859fae6 (diff)
Added by Ian Ballou 8 months ago

Fixes #33629 - 4.0 upgrade migration fails due to validation

History

#1 Updated by Ian Ballou 8 months ago

  • Subject changed from In Katello 4.1 upgrade, installer failed with exit status 6 in the db:migrate stage. to In Katello 4.1 upgrade, installer failed with exit status 6 in the db:migrate stage.

Edit: the issue occurs when going from 3.18 to 4.0, not 4.0 to 4.1.

#2 Updated by The Foreman Bot 8 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9693 added

#3 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases Katello 4.3.0 added

#4 Updated by Anonymous 8 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Ian Ballou 8 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.1

Also available in: Atom PDF