Project

General

Profile

Bug #498

facts not displayed for openvz guests

Added by Chris ECN over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Importers
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

My physical hosts show their facts correctly in foreman, however the openvz guests do not display facts at the following URLS:

/hosts/ > Operating system, Environment, Model < These columns are blank

/hosts/$hostname > IP Address, Puppet Environment, Host Architecture, Host Operating System < these entries are blank

If I select 'Facts' for one of these hosts, I see all of the facts correctly, however, they do not have a 'productname' fact

History

#1 Updated by Ohad Levy over 8 years ago

can you please upload an example fact file of an openvz machine?

#3 Updated by keith obrien almost 8 years ago

I just wanted to confirm that I am having the same issue.

Please let me know if there is any additional information you would like about my setup.

Thanks,
Keith.

#4 Updated by Ohad Levy almost 8 years ago

I've just had a look, and it seems that the latest git version solves this issue.

can you please give it a try and confirm?

thanks

#5 Updated by keith obrien almost 8 years ago

Confirm fix using git source. Nightly did not yet have the fix.

Thanks,
Keith.

#6 Updated by Ohad Levy almost 8 years ago

keith obrien wrote:

Confirm fix using git source. Nightly did not yet have the fix.

thanks.. nightly is generated automatically once a day, maybe you fetched it before :)

#7 Updated by Ohad Levy almost 8 years ago

  • Category set to Importers
  • Status changed from New to Closed
  • Assignee set to Ohad Levy
  • Target version set to 0.3

Also available in: Atom PDF